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Лабораторная работа №1 
 
СОЗДАНИЕ БИБЛИОТЕКИ КОМПОНЕНТОВ В САПР PCAD 2001 
 

1. Цель работы 
Изучить методы и алгоритмы создания компонентов в пакете прикладных 

программ PCAD 2001 для компьютерного проектирования схем электрических 
принципиальных и печатных плат электронных устройств. 

 
2. Краткие теоретические сведения 

Система автоматизированного проектирования (САПР) электронной аппа-
ратуры PCAD  на сегодняшний день является одной из самых мощных, полных 
и последовательных систем автоматизированного проектирования для персо-
нальных компьютеров. 

САПР PCAD  представляет собой пакет специализированных модулей, тес-
но связанных друг с другом и охватывающих все этапы разработки и изготовле-
ния однослойных и многослойных печатных плат. 

Программные средства системы позволяют автоматизировать весь процесс 
проектирования электронных средств, начиная с ввода принципиальной схемы, 
ее моделирования, упаковки схемы на печатную плату, интерактивного разме-
щения радиоэлектронных компонентов  на плате и автотрассировки соединений, 
вплоть до получения конструкторской документации и подготовки информации 
для производства плат на технологическом оборудовании. 

Поставляемые с системой PCAD библиотеки не соответствуют белорусским 
стандартам, поэтому для успешного проектирования печатных плат важно уметь 
создавать новые библиотечные компоненты и редактировать старые.  

Интегрированные библиотеки PCAD 2001 содержат компоненты 
(components), корпуса (pattern) и символы (symbol). На схеме компонент пред-
ставлен символом, а на печатной плате корпусом. Кроме графики символа и 
корпуса в библиотеке содержится информация об упаковке в корпус (подвод пи-
тания, подключение выводов и т.д.). Единство символа, графики корпуса и упа-
ковочной информации и составляет понятие компонента. Преимущество интег-
рированных библиотек заключается в том, что упаковочная информация для ка-
ждого компонента хранится в одном месте и должна вводиться всего один раз. 

Поэтому при создании библиотеки компонентов в PCAD  2001 необходимо: 
1) создать новую библиотеку; 
2) в редакторе Symbol Editor создать символ компонента и сохранить его в 

библиотеку под своим именем; 
3) в редакторе Pattern Editor создать корпус компонента и сохранить его в 

библиотеку под своим именем; 
4) в блоке Library Executive произвести объединение (упаковку) корпуса и 

символа в один компонент. 
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2.1. Редактор символов Symbol Editor 

Создавать символы компонентов можно тремя различными способами: 
1) в редакторе  PCAD  Schematic; 
2) в редакторе PCAD  Symbol Editor; 
3) путем редактирования существующего символа компонента. 
Наиболее удобно создавать символы компонентов в редакторе PCAD  Sym-

bol Editor. 
Редактор PCAD  Symbol Editor имеет аналогичный с основным редактором 

PCAD  Schematic экран (рис. 1.1). Он имеет набор команд, необходимых для ре-
дактирования символов компонентов и аналогичных соответствующим коман-
дам PCAD  Schematic за исключением команд меню File. В PCAD  Symbol Editor 
работают с файлами библиотек (*.LIB) и отдельных символов (*.SYM). Система 
единиц, набор толщин линий и ряд других глобальных параметров  
PCAD  Symbol Editor сохраняются в файле конфигурации SymEd.INI: например, 
система единиц устанавливается с помощью ключевого слова Units, принимаю-
щего значения 0 — mil, 1 — inch, 2 — мм. По умолчанию устанавливается сетка 
100 mil или 2,54 мм, поэтому необходимо предварительно настраивать парамет-
ры редактора в меню Options. 

 

 
Рис. 1.1. Диалоговое окно Symbol Editor 

При создании символов компонентов с большим количеством выводов удо-
бен  «Мастер Символов», вызываемый по команде Symbol Wizard меню Symbol 
или кнопкой . В его диалоговом окне (рис. 1.2) указывается следующая ин-
формация: Symbol Width — ширина символа; Pin Spacing — расстояние между 
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смежными выводами; Length — длина вывода (Short, Normal, Long, User); Num-
ber Pin Left (Right) — количество выводов на левой (правой) стороне символа; 
Symbol Outline — необходимость изображать контур символа; Line Width — 
ширина линии контура символа; Display Pin Name (Pin Des) — необходимость 
указывать на чертеже символа имена (номера) выводов; Default Pin Name — 
имя первого вывода, принимаемое по умолчанию (не более 20 символов); De-
fault Pin Designator — номер первого вывода, принимаемый по умолчанию; 
Current Pin Number — порядковый номер текущего вывода. 

 

 
Рис. 1.2. Диалоговое окно Symbol Wizard 

 
Нажатие на клавишу Finish завершает создание символа и его изображение 

заносится в библиотеку по команде Symbol>Save или Symbol>Save As. В связи 
с тем, что Мастер всегда создает прямоугольный символ без разбиения на зоны, 
графику символа обычно требуется редактировать.  

При ручном рисовании символа полезна команда Place>Pin, диалоговое ок-
но которой (рис. 1.3) в удобной форме содержит всю информацию, необходи-
мую для настройки режима размещения выводов символов, и окно для просмот-
ра их графики. 

В меню Utils (см. рис. 1.1) включена команда Validate, предназначенная для 
проверки корректности создания символа компонента: при наличии ошибок та-
кой символ не разрешается заносить в библиотеку. 

С помощью PCAD  Symbol Editor вводятся атрибуты символов, сохраняе-
мые в библиотеках. Эти атрибуты вводятся и редактируются по команде 
Symbol>Attributes  или по команде Place>Attribute . Удобнее вводить ат-
рибуты с помощью PCAD  Symbol Editor, а не с помощью PCAD  Schematic, так 
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как при создании библиотеки компонентов с однотипными атрибутами проще их 
ввести один раз, копировать вместе с символом и затем редактировать. 

 
Рис. 1.3. Диалоговое окно Place Pin 

 
Для копирования символа он сначала загружается по команде  

Symbol>Open (если символ находится не в отдельном файле, а в библиотеке, 
предварительно указывается ее имя). После внесения изменений в атрибуты 
символ сохраняется по команде Symbol>Save As. Если отметить при этом оп-
цию Create Component, созданный символ можно сразу же наносить на схему 
без описания корпуса и информации об упаковке элемента. 

 
2.2. Редактор корпусов Pattern Editor 

Создавать корпуса компонентов можно тремя различными способами: 
1) в редакторе  PCAD  РСВ; 
2) в редакторе PCAD  Pattern Editor; 
3) путем редактирования существующего корпуса компонента. 
Наиболее удобно создавать символы компонентов в редакторе PCAD   

Pattern Editor.  
При создании корпуса компонента необходимо помнить, что создается про-

екция корпуса на плату с формованными выводами. В общем случае вид проек-
ции корпуса может значительно отличатся от внешнего вида корпуса компонен-
та. 

Экран редактора корпусов компонентов PCAD  Pattern Editor (рис. 1.4) в ос-
новном такой же, как экран основного редактора PCAD  PCB. PCAD  Pattern 
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Editor имеет набор команд, необходимых для редактирования корпусов компо-
нентов. В PCAD  Pattern Editor работают с файлами библиотек (*.LIB) и отдель-
ных корпусов (*.РАТ). 

 

 
Рис. 1.4. Экран PCAD  Pattern Editor 

 
В PCAD  Pattern Editor параметры конфигурации сохраняются в файлах от-

дельных символов «*.РАТ». Поэтому можно установить необходимый набор се-
ток и сохранить «пустой» файл шаблона корпуса по команде 
File>Copy To File As. Система единиц и ряд других глобальных параметров со-
храняются в файле конфигурации PatEd.INI. Перед вызовом программы PCAD  
Pattern Editor устанавливается нужный файл конфигурации и по команде 
File>Open загружается шаблон корпуса. 

По команде Pattern Wizard или кнопкой  вызывается «Мастер создания 
корпусов компонентов». В его диалоговом окне (рис. 1.5) указывается следую-
щая информация: Pattern Type - тип корпуса (посадочного места) компонента; 
Number of Pads Down - число строк выводов; Number of Pads Across - число 
столбцов в массиве выводов; Pad to Pad Spacing (On Center) - расстояние меж-
ду центрами выводов; Pattern Width - расстояние между крайними столбцами 
выводов (для корпусов DIP, QUAD); Pattern Heigh - расстояние между крайни-
ми строками выводов (для корпуса QUAD); Pad 1 Position - расположение пер-
вого вывода (для корпусов DIP, QUAD); Pad Style - тип стека контактной пло-
щадки (КП) (отдельно для первого и остальных выводов); Silk Screen - необхо-
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димость изображения контура корпуса; Silk Line Width - ширина линий контура 
корпуса; Silk Rectangle Pattern Width - ширина корпуса компонента; Silk Rec-
tangle Pattern Height - высота корпуса компонента; Rotate - признак поворота 
контактных площадок на 90°; Notch Type - тип скоса графики корпуса компо-
нента (в верхнем левом углу, в нижнем левом углу и т. п.). 

 

 
Рис. 1.5. Диалоговое окно PCAD  Pattern Wizard 

 
Нажатие на клавишу Finish завершает создание корпуса компонента, после 

чего его изображение переносится на основной экран программы Pattern Editor. 
Здесь его графику можно обычным способом отредактировать и затем занести в 
библиотеку по команде Pattern>Save или Pattern>Save As. 

Одному символу компонента может соответствовать несколько корпусов 
(DIP, SMT, flat-pack и т.п.). По команде Pattern>Add Pattern Graphics  к ос-
новному изображению графики корпуса компонента (оно по умолчанию носит 
название Primary) добавляется альтернативное (рис. 1.6). Назначение альтерна-
тивных корпусов выполняется в программе Library Executive по команде  
Library>Pattern Graphics. 
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Рис. 1.6. Добавление альтернативного корпуса компонента 

 
При редактировании существующего корпуса в рабочее окно редактора по-

мещают изображение корпуса, хранящееся в библиотеке как единый объект. За-
тем его преобразуют в набор графических примитивов, что дает возможность 
внесения изменений и дополнений. После модификации корпус заносится в биб-
лиотеку под новым именем и сохраняется как единое целое. Последовательность 
действий такова. 

1. Нажатием пиктограммы  включают режим выбора объектов и указы-
вают редактируемый корпус щелчком левой кнопки мыши. 

2. По команде Edit>Explode Component выбранный корпус преобразуется 
в набор графических примитивов — если до выполнения этой команды корпус 
представлял собой единое целое, то теперь доступны для редактирования все его 
составные части (выводы, линии, надписи и т.п.). Если добавлены или удалены 
выводы компонента, то нужно заново их пронумеровать по команде 
Utils>Renumber. Для этого перед выполнением команды включают режим вы-
бора объектов, а в меню команды указывают режим перенумерации выводов 
Pad Number. После закрытия меню команды все выводы, подлежащие перену-
мерации, по очереди помечают щелчком мыши в порядке возрастания их номе-
ров, начиная с первого (перенумерованные выводы окрашиваются). 

3. После внесения всех изменений корпус заносят в библиотеку. Сначала 
выполняют операцию блочного выбора всех принадлежащих ему графических 
объектов, заключая их в прямоугольную рамку. Далее по команде 
Library>Pattern Save As заносят корпус в библиотеку. В списке Library выби-
рают имя одной из открытых библиотек и в графе Pattern вводят имя нового 
корпуса. Если компонент в целом будет создаваться в дальнейшем с помощью 
Library Executive или Library Manager, не нужно включать опцию 
Create Component. 

 
2.3. Менеджер библиотек компонентов 

В системе PCAD  поддерживаются два типа библиотек:  
1) интегрированные библиотеки компонентов; 
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2) отдельные библиотеки символов и корпусов компонентов.  
В интегрированную библиотеку заносятся данные трех типов:  
1) текстовая информация о компонентах;  
2) графика корпусов; 
3) графика символов компонентов.  
Способы создания графики корпусов и символов указаны выше. Менеджер 

библиотек Library Manager или Library Executive заносит эти данные в интегри-
рованную библиотеку и добавляет текстовую информацию о компонентах. 

Использование интегрированные библиотеки при проектировании печат-
ных плат в PCAD  предпочтительнее, так как это позволяет выполнять: 

− “горячую связь” между графическими редакторами; 
− прямую и обратную корректировку проекта; 
− перестановку логически эквивалентных выводов и секций компонентов. 
Содержание загруженных библиотек просматривают в графических редак-

торах по команде Place>Part или Place>Component, а также в менеджере биб-
лиотек по команде Component>Open. 

Library Executive имеет ряд дополнительных средств по сравнению с  
Library Manage: 

− включена команда Query для поиска компонентов в библиотеках по за-
данному набору атрибутов; 

− при использовании Library Executive возможно применение редактора 
символов Symbol Editor и редактора корпусов Pattern Editor.  

Упаковка компонентов в Library Executive – самый трудоемкий и ответст-
венный этап в создании библиотечного компонента. Неправильное заполнение 
таблицы упаковки ведет к ошибочной трассировке печатной платы и даже к не-
возможности ее проектирования. 

После загрузки программы Library Executive на строке инструментов дос-
тупны только пиктограммы Component>New, Component>Open и View>Source 
Browser  (недоступные пиктограммы и строки меню окрашены в серый цвет, 
при вызове Source Browser щелчком правой кнопки мыши открывается выпа-
дающее меню, содержание которого зависит от типа объекта, выбранного в ок-
не). После загрузки существующего компонента или открытия нового по коман-
дам Component>Open, Component>New на экране появляется диалоговое окно 
Component Information, показанное в левом верхнем углу рис. 1.7.  

На трех остальных окнах этого рисунка представлена детальная информа-
ция о компоненте, позволяющая установить связь между выводами символа и 
корпуса компонента. Всего меню Library Executive имеет четыре основных окна. 

1. Окно Component Information. В этом окне представлена общая инфор-
мация о компоненте: 

− в строке Select Pattern выбирается тип корпуса компонента, например 
SO 14; 
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Рис. 1.7. Подробная информация о компоненте на экране Library Manager 

 
− в строке Number of Gates — задается число секций в компоненте; 
− в строке Number of Pads — указывается общее число выводов; 
− в строке Refdes Prefix — задается префикс позиционного обозначения 

компонента; 
− в разделе Component Type выбирают тип компонента (который принима-

ется во внимание при составлении списков соединений и заполнении граф отче-
тов о проекте): 

Normal — обычный компонент; Power— источник питания (компоненты та-
кого типа, в частности, не включаются в списки соединений для «упаковки» 
схемы на ПП, но включаются в списки соединений для выполнения моделиро-
вания); Sheet Connector — соединитель листов схемы; Module — символ (модуль) 
иерархической структуры; Link — связь символа модуля иерархической структу-
ры с его схемой;  

− в разделе Component Style выбирают: 
Homogeneous — однородный компонент (все секции однотипны); 
Heterogeneous — неоднородный компонент (секции разных типов); 
− в разделе Gate Numbering задают способ нумерации секций: 
Alphabetic — буквенный; Numeric — числовой (рекомендуется); 
− в разделе Alternate Views указывают альтернативные изображения сим-

волов. 
В нижней части окна располагается таблица, где для каждого типа секций 

указаны: 
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Gate # — номер секции; 
Gate Eq — код логической эквивалентности секции (секции, имеющие оди-

наковый отличный от нуля код эквивалентности, могут переставляться при оп-
тимизации цепей на печатной плате); 

Normal — имя символа в нормальном изображении. 
Альтернативные обозначения символов можно использовать для введения 

их изображений по ЕСКД. 
Вверху располагаются кнопки Pins View, Pattern View и Symbol View для 

открытия окон редактирования параметров выводов компонентов. 
2. Окно Symbol View. В нем приведено изображение символа текущего 

компонента и таблица с информацией о его выводах. Каждому выводу компо-
нента отведена одна строка. В столбцах указана следующая информация: 

Pad # — номер вывода компонента; 
Pin Des — физический номер вывода компонента в корпусе; 
Gate # — номер секции компонента; 
Sym Pin # — порядковый номер вывода символа компонента в пределах 

секции; 
Pin Name — имя вывода символа секции компонента; 
Gate Eq — код логической эквивалентности секции компонента; 
Pin Eq — код логической эквивалентности вывода секции; 
Elec. Type — электрический тип вывода, необходимый для проверки прин-

ципиальной схемы: 
Unknown - неизвестный; Passive - вывод пассивного компонента; Input - 

вход; Output - выход; Bidirectional - двунаправленный вывод; Ореп-Н - вывод 
секции с открытым эмиттером; Open-L - вывод секции с открытым коллектором; 
Passive-H - вывод пассивного компонента, подключенный к источнику высокого 
потенциала; Passive-L - вывод пассивного компонента, подключенный к источ-
нику низкого потенциала; 3-State – 3-стабильный вывод; Power - вывод цепи пи-
тания. 

Нажатие на кнопку Select Symbol позволяет изменить символ, назначенный 
текущему компоненту. 

3. Окно Pattern View. В нем приведено изображение корпуса текущего 
компонента и таблица с информацией о его выводах. Нажатие на кнопку  
Select Pattern позволяет изменить корпус, назначенный текущему компоненту. 

4. Окно Pins View. В нем приведена таблица с информацией о всех выводах 
компонента, наиболее удобная для редактирования. После выбора курсором ка-
кой-либо ячейки выше таблицы появляется строка с информацией о занесенных 
в нее данных и панель для их редактирования. 

 

Каждый компонент библиотеки состоит из одной или нескольких логиче-
ских секций (gates), которые упаковываются в корпус. Несколько разных компо-
нентов могут упаковываться в один и тот же типовой корпус. 

Редактор PCAD  РСВ не может использовать информацию только о компо-
ненте (так как это только текстовая информация) или только о корпусе (так как 

Би
бл
ио
те
ка

 БГ
УИ
Р



 

это только графическая информация), для него необходимы совместные данные 
компонент/корпус. Аналогично для редактора PCAD  Schematic необходимы со-
вместные данные компонент/символ. Когда компонент размещается на ПП или 
на схеме, используется графика корпусов или символов, на которые сделаны 
ссылки в описании компонента. Разные компоненты могут ссылаться на одну и 
ту же графику корпусов или символов. Корпуса и символы, на которые имеются 
ссылки в компонентах, должны находиться в одной и той же библиотеке. 

Ссылки в разных компонентах на одни и те же корпуса и символы значи-
тельно экономят память, занимаемую библиотекой. Кроме того, редактирование 
типовых корпусов и символов сразу вносит изменения в графику всех родствен-
ных компонентов.  

При работе с библиотекой компонентов важно различать следующие ос-
новные понятия (рис. 1.8): 

 

 
   а     б 
 

Рис. 1.8. Изображение компонента на схеме (а) и на ПП (б) ИС  K155ЛАЗ 
 

Pad Number — порядковый номер вывода компонента (обычно совпадает с 
физическим номером вывода, но это необязательно); 

Pin Designator — физический номер вывода в корпусе; 
(Symbol) Pin Number — номер вывода в пределах секции компонента; 
Pin Name — имя вывода (в секции компонента). 
Работа с библиотеками значительно облегчается с помощью окна просмот-

ра Source Browser и команды поиска Query. 
Окно просмотра Source Browser (рис. 1.9) открывается по команде 

View>Source Browser. В нем отображается дерево библиотек, открытых по  
команде Library>Setup. Каждая библиотека состоит из разделов Components, 
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Patterns и Symbols. Двойной щелчок курсора мыши по символу или компоненту 
открывает окно просмотра их изображения. Щелчок правой кнопки мыши по 
компоненту открывает всплывающее меню, содержащее две строки: Open и 
Place. Выбор варианта Open открывает окно Component Information с предостав-
лением возможностей редактирования параметров компонента. Выбор варианта 
Place позволяет по дополнительному выбору (РСВ, Schematic) разместить сим-
вол компонента на схеме или его корпус на ПП (для этого предварительно 
должна быть открыта программа PCAD  РСВ или Schematic).  

 

 
Рис. 1.9. Окно просмотра Source Browser 

 
Изображение иконки компонента в окне просмотра свидетельствует о нали-

чии у него присоединенного корпуса и/или символа. 
 

3. Порядок выполнения работы 
1. Изучить теоретический материал. 
2. Создать в PCAD  библиотечный компонент 155ЛАЗ. 
3. Получить индивидуальное задание у преподавателя согласно варианту 

(приложение). 
4. Создать новую библиотеку с заданными преподавателем компонентами. 
5. Получить распечатку результатов выполнения работы. 
6. Оформить отчет по лабораторной работе. 
 

4. Практический пример создания библиотечного компонента 
Опишем последовательность создания компонентов на примере интеграль-
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ной схемы однородной структуры со штыревыми выводами 155ЛАЗ - четырех 
логических элементов 2И-НЕ (компоненты с планарными выводами создаются 
так же). 

Создание символа компонента в PCAD  Symbol Editor. Для создания 
символа компонента K155ЛАЗ (рис. 1.8, а) создадим лишь одну секцию (т.к. ос-
тальные три будут такими же) – логический элемент 2И-НЕ. Для этого необхо-
димо выполнить следующую последовательность действий: 

1. Загрузить редактор Symbol Editor. 
2. Выбрать меню Options>Configure и установить следующие параметры 

конфигурации: Workspace Size – выбрать необходимый формат чертежа (на вы-
бор предлагаются американская и европейская системы обозначения), например 
А4, систему единиц Units установить метрическую (mm), в Orthogonal Modes 
можно разрешить/запретить рисование под прямыми углами (90°) и под углами 
в 45°. 

3. Выбрать меню Options>Grids и в поле Grid Spacing ввести значение 
2,5 мм и нажать кнопку Add (старое значение можно удалить). 

4. Запустить Symbol Wizard либо через меню Symbol>Symbol Wizard, либо 
нажав на соответствующую кнопу в виде желтой молнии  на панели инстру-
ментов. 

5. Заполнить соответствующие поля исходя из задания. 
 Symbol Width – ширина символа (изменяем на 10 мм) 
 Pin Spacing – расстояние между смежными выводами (изменяем 5 мм). 
 Length – длина вывода (рекомендуется User=5 мм). 
 Number Pins Left (Right) – количество выводов на левой (правой) стороне 

символа (2 вывода). 
 Symbol Outline – необходимость изображать контур символа (необходимо 

включить). 
 Line Width – ширина линии контура символа (рекомендуется 0,2 мм). 
 Display Pin Name (Pin Des) – необходимость указывать на чертеже симво-

ла имена (номера) выводов (необходимо включить). 
 Default Pin Name – имя первого вывода, принимаемое по умолчанию. Его 

можно задать позднее, сделав двойной щелчок мышью на соответствующем вы-
воде. 

 Default Pin Designator – номер первого вывода, принимаемый по умолча-
нию (можно не задавать). 

 Current Pin Number – порядковый номер текущего вывода (менять не ре-
комендуется). 

После установки необходимых параметров необходимо нажать на кнопку 
Finish. 

6. Задать имена выводам. Двойным щелчком мыши по верхнему левому вы-
воду откроем окно его свойств и заполним следующие поля: Default Pin Name = 
in1, Default Pin Des = Pin Number (если система правильно ввела нумерацию 
для первой секции, для которой мы создаем символ, иначе Pin Number придется 
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приводить в соответствие с заданием). Соответственно для нижнего левого вы-
вода Default Pin Name = in2, для правого вывода Default Pin Name = out. Имена 
можно вводить и позднее на этапе создания компонента в менеджере библиотек 
компонентов Library Executive. 

Осуществить проверку на наличие ошибок, нажав кнопку . Если все в 
порядке, переходим к п. 7. 

7. Отредактировать (если необходимо) графику символа компонента, ис-
пользуя возможности редактора (панель инструментов, кнопка со знаком ∑ по-
зволяет ввести логические символы, кнопка с буквой А позволяет ввести текст и 
т.д.). В нашем случае можно поднять вывод «Out» на 2,5мм выше, чтобы он рас-
полагался посередине символа, а также ввести текстом внутри границ нашего 
символа знак «&». Далее два раза щелкнув мышью по выводу «Out», попадем в 
его свойства, и в разделе Outside Edge отметить параметр Dot (для обозначения 
инверсии сигнала). Окончательный вид показан на рис 1.10. 

 

 
Рис. 1.10. Созданный символ 

 
8. Создать новую библиотеку по команде Library>New и записать изобра-

жение символа компонента по команде меню Symbol>Save as. Нажав на кнопку 
Library, выбираем место размещения и имя библиотеки, в строке Symbol указы-
ваем имя компонента, например K155LA3 (лучше указывать латинскими бук-
вами, т.к. русские могут некорректно отображаться!!!), также необходимо 
включить опцию Match Default Pin Designator to Pin Numbers и нажать кнопку 
ОК (для односекционных компонентов этого лучше не делать во избежание пу-
таницы с нумерацией выводов). На этом создание символа компонента заверше-
но. 

 

Создание корпуса компонента в PCAD  Pattern Editor. Для микросхемы 
K155ЛА3 выбираем корпус типа «SO» (для поверхностного монтажа). 

Для создания корпуса необходимо выполнить следующие действия: 
1. Загрузить Pattern Editor. 
2. Выбрать в меню Options>Configure и Options>Grids параметры, анало-

гичные параметрам Symbol Editor. 
3. Создать в меню Options>Pad Style новый стек контактных площадок 

(прямоугольная площадка – для поверхностного монтажа). 
4. Запустить Pattern Wizard через меню Pattern>Pattern Wizard или нажав 
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на соответствующую кнопку в виде желтой молнии на панели инструментов. 
5. Заполнить соответствующие поля (рис. 1.11): 
 Pattern Type – тип корпуса (посадочного места) компонента (выбираем 

DIP). 
 Number of Pads Down – число строк выводов (14 для корпуса с 14-ю вы-

водами). 
 Pad to Pad Spacing (On Center) – расстояние между центрами выводов 

(1,25 мм). 
 Pattern Width – расстояние между крайними столбцами выводов (7,5 мм). 
 Silk Line Width – ширина линии контура корпуса (рекомендуется 

0,25 мм). 
 Silk Rectangle Width – ширина корпуса компонента (5 мм). 
 Silk Rectangle High – высота корпуса компонента (9 мм). 
 Pattern Width – расстояние между крайними столбцами выводов (7,5 мм). 
 Notch Type – вид обозначения первого вывода корпуса (Arc). 
 Pad Style – стиль контактных площадок (New – созданный в п. 3). 
 

 
Рис. 1.11. Созданный корпус 

 
После установки необходимых параметров нажать на кнопку Finish. Также 

необходимо осуществить проверку на наличие ошибок, нажав кнопку .  
6. Записать изображение корпуса по команде Pattern >Save as в библиотеку 

(записывать необходимо в ту же библиотеку, куда был записан символ микро-
схемы). Нажав на кнопку Library, выбираем место размещения и имя библиотеки 
(рис. 1.12), в строке Pattern указываем имя компонента, например SO 14 (т.к. 
корпус у нас стандартный), и нажимаем кнопку ОК. На этом создание корпуса 
компонента завершено. 
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Рис. 1.12. Занесение корпуса компонента в библиотеку 

 
 

Создание компонента с помощью Library Executive. После загрузки 
Library Executive выполняется команда Component>New, и в ее диалоговом окне 
указывают файл библиотеки, в который ранее занесены корпус и символ компо-
нента. Затем на экран выводится окно Component Information (рис. 1.13). В нем 
сначала нажимают кнопку Select Pattern для подключения графики корпуса 
компонента. В открывшемся окне Library Browse из списка корпусов, поме-
щенных в открытую библиотеку, выбирают нужный - в рассматриваемом при-
мере это SO 14. Затем вводят следующую информацию. 

 

 
Рис. 1.13. Меню Component Information 

 
1. В строке Number of Gates указывают число секций, в данном приме-

ре - 4. Число выводов компонента проставляется на строке Number of Pads  
автоматически. В строке Refdes Prefix указывают префикс позиционного обо-
значения компонента, в данном примере - DD. После этого становится доступ-
ной панель Select Symbol, после нажатия на которую выбирают имя основного 
изображения символа компонента, в данном примере это 155ЛА3. 
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2. В графе Component Type выбирают тип компонента Normal. 
3. В графе Component Style для однородного компонента выбирают строку 

Homogeneous. 
4. В графе Gate Numbering выбирают цифровой способ именования секций 

компонента Numeric (первая секция в графе Gate # в таблице на рис. 1.13 полу-
чит номер 1, вторая - 2 и т.п.). Все секции однородных компонентов по умолча-
нию получают одинаковый код логической эквивалентности Gate Eq, что по-
зволит их автоматически переставлять в процессе размещения компонентов на 
ПП. 

Редактирование таблицы выводов компонента. Создание компонента 
завершается заполнением таблицы выводов, которая выводится на экран нажа-
тием кнопки Pins View (рис. 1.14, а). Это самая трудоемкая часть работы по соз-
данию компонента. 

Во-первых, нужно установить соответствие между номерами выводов всех 
секций Sym Pin # и позиционными обозначениями выводов корпуса Pin Des. 

В интегральной схеме серии К155 вывод 7 соединяется с «землей» (GND), а 
вывод 14 с источником питания (VСС). 

Сначала скопируем содержание столбца Pad # в столбец Pin Des. Видно, что 
информация о номерах выводов секций 2, 3 и 4 не соответствует ИС серии К155, 
и ее необходимо исправить, редактируя соответствующие строки таблицы. 

Таблица выводов компонентов Pins View заполняется следующим образом. 
В нашем случае (см. рис. 1.14, а) мы видим, что во многих столбцах таблицы от-
сутствуют записи. Столбцы Sym Pin # и Pin Name заполнены только для одной 
1-й секции, поэтому в столбце Gate # (туда заносятся номера секций) в строки 1, 
2 и 3 необходимо записать единицы. Информация для остальных секций запол-
няется в соответствии с секцией 1, т.е. если для секции 1 известно, какие выводы 
символа сопоставить с реальными выводами микросхемы, то теперь необходимо 
выводы 2-, 3- и 4-й секции тоже логически связать с реальными выводами мик-
росхемы, но на основе примера секции 1. Для этого нужно правильно заполнить 
столбцы Sym Pin #  и  Pin Name.  

В соответствии с логической структурой компонента K155ЛАЗ (см. рис. 1.8, 
а) ко второй секции относятся выводы 4, 5 и 6 микросхемы, поэтому в строки 4, 
5, 6 столбца Gate # занесем двойки. Далее аналогичным образом перенесем зна-
чения столбцов Sym Pin #  и  Pin Name из секции 1, т.е. в строку 4 в столбцы 
Sym Pin #  и  Pin Name запишем значения «1» и «in1» соответственно, в строку 
5 в эти же столбцы запишем значения «2» и «in2», в строку 6 запишем значения 
«3» и «out». Аналогичным образом заполняются остальные ячейки таблицы.  

Вывод 7 должен получить имя GND, а вывод 14 - VCC, а в столбце - 
Elec. Type им необходимо присвоить тип Power. Полностью заполненная таб-
лица представлена на рис. 1.14, б. 
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Рис. 1.14. Таблица выводов компонента до (а) и после редактирования (б) 
 

В столбце Pin Name можно вводить (если при создании символа компонен-
та имя не задавалось) или изменять имена выводов. Для этого курсором выделим 
соответствующую ячейку и введем необходимую информацию, которая появля-
ется в строке над таблицей. Нажатием кнопки  или Enter введенные данные 
переносятся в выделенную ячейку. Нажатие  или Esc отменяет ввод. Копиро-
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вание данных выделенной ячейки (или нескольких ячеек) производят нажатием 
клавиши Ctrl+C или Ctrl+Ins (либо правой кнопки мыши, выбирая пункт в вы-
падающем меню), затем выделяют ячейку (или ячейки), куда нужно эти данные 
скопировать, и нажимают комбинацию клавиш Ctrl+V или Shift+Ins (обычная 
техника для Windows). 

Эквивалентность секций (или выводов) подразумевает возможность менять 
местами секции (выводы) для удобства прокладки трасс автотрассировщиком 
печатных плат. В столбце Gate Eq указывается эквивалентность секций. 

В нашем случае установка в любой ячейке любой секции единицы приведет 
к автоматической расстановке единиц и в ячейках, относящихся к другим секци-
ям, потому что секции у нас одинаковые (т.е. компонент однородный), а значит, 
они эквивалентны. 

Аналогичным образом необходимо заполнять и столбец Pin Eq. Для нашего 
случая необходимо занести единицы в строки с именами in1 и in2. Эквивалент-
ность выводов действует только в пределах одной секции. 

В столбце Elec. Type указывается тип вывода, используемый при поиске 
ошибок в принципиальных электрических схемах. Нажатие на правую кнопку 
мыши (либо на кнопку  с выпадающим списком) открывает выпадающий спи-
сок типов выводов (Electrical Type). Для быстрого выбора типа вывода доста-
точно напечатать первый символ его имени. Например, ввод символа I присваи-
вает тип Input.  

Примечание. Для простановки символа логической инверсии в имени выво-
да используется знак «∼». Так, имя G  следует ввести как ~G, имя AGC2  - как 
GC~2A. 

 

Сохранение компонента в библиотеке. Перед сохранением в библиотеке 
компонента необходимо выполнить команду проверки Component>Validate 
(кнопка ). При обнаружении ошибок выводятся соответствующие информа-
ционные сообщения. Если же ошибок не обнаружено, программа сообщает: No 
errors found! 

После исправления всех ошибок выполняется команда сохранения компо-
нента в текущей библиотеке Component>Save или Component>Save As. Однако 
перед выполнением этих команд обязательно проверяется наличие ошибок, и 
пока ошибки не исправлены, компонент сохранить нельзя. Имя нового компо-
нента указывают по дополнительному запросу (рис. 1.15). 

 

 
Рис. 1.15. Сохранение компонента в текущей библиотеке 

 
5. Содержание отчета 

1. Цель работы. 

Би
бл
ио
те
ка

 БГ
УИ
Р



 

2. Результаты выполнения работы в виде таблиц упаковки библиотечных 
компонентов, графические изображения символов и корпусов компонентов со-
гласно индивидуального задания. 

3. Электронная версия созданной библиотеки PCAD. 
4. Выводы по работе. 
 

6. Контрольные вопросы 
1. Создание каких типов компонентов возможно в PCAD? 
2. Алгоритм создания нового библиотечного компонента. 
3. Основные отличия Library Manager или Library Executive. 
4. Какие данные заносятся в интегрированные библиотеки? 
5. Способы создания символа и корпуса компонента. 
6. Особенности создания однородных и неоднородных компонентов. 
7. Что подразумевается под эквивалентностью секций и выводов компонен-

тов? 
8. Особенности создания безвыводных компонентов для поверхностного 

монтажа. 
9. Алгоритм создание интегрированного библиотечного компонента с раз-

личными корпусами. 
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Лабораторная работа № 2 
 

СОЗДАНИЕ МОДЕЛИ СХЕМЫ ЭЛЕКТРИЧЕСКОЙ 
ПРИНЦИПИАЛЬНОЙ В РЕДАКТОРЕ SHEMATIC PCAD 2001 

 
1. Цель работы 

Изучить методы и алгоритмы создания принципиальных схем для  даль-
нейшего проектирования печатных плат, а также научиться транслировать спи-
сок цепей схемы в программу PCAD РСВ для последующего проектирования 
печатных плат. 

 
2. Краткие теоретические сведения 

Редактор PCAD SHEMATIC предназначен для построения схем электриче-
ских из библиотечных компонентов с последующей передачей информации об 
электрических связях между компонентами в PCAD PCB для проектирования 
печатной платы. PCAD SHEMATIC можно использовать также для оформления 
конструкторской документации (схем электрических принципиальных, перечней 
документов и т.п.). 

Внешний вид экрана монитора при запуске PCAD Schematic показан на рис. 
2.1. 

 
Рис.  2.1. Экран PCAD Schematic с загруженной схемой 
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После запуска редактора схем PCAD Schematic рекомендуется настроить 
его конфигурацию: определить размер листа схемы и настроить другие парамет-
ры в меню команд Options > Configure (рис. 2.2).  

 

 
Рис. 2.2. Настройка конфигурации PCAD Schematic 

 
В графе Units выбирают систему единиц - миллиметры. Изменить систему 

единиц можно на любой фазе работы со схемой без потери точности. О текущей 
системе единиц можно судить по размерности ширины линий, указываемой на 
строке состояний. 

Режим ввода цепей и линий устанавливают в графе Orthogonal Modes: 
90/90 Line-Line — ввод ортогональных линий, 45/90 Line-Line — ввод диаго-
нальных линий. При включении режима 90/90 Line-Line линии проводятся по 
осям координат или под произвольным углом, при включении режима 45/90 
Line-Line — по диагоналям или под произвольным углом. Рекомендуется вклю-
чить оба режима, тогда линии проводятся по осям координат, по диагоналям или 
под произвольным углом, что определяется дополнительным нажатием клавиши 
О. 

Переключатель DDE Hotlinks устанавливает режим взаимного выделения 
цепей между графическими редакторами PCAD Schematic и PCAD РСВ (так на-
зываемую горячую связь). 

Шаг сетки устанавливают в меню Option>Grids. Текущее значение шага 
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сетки выбирают курсором в списке Grids или, что более удобно, непосредствен-
но на строке состояний. 

В меню Options>Display задают цвета различных объектов, стиль изобра-
жение шин и ряд других параметров (рис. 2.3). 

 

 
Рис. 2.3. Настройка параметров дисплея 

 
В окне Bus Connection Mode указывают один из трех стилей изображения 

подсоединения цепей к шине. 
В окне Junction Size выбирают размер точки электрического соединения 

цепей (точки «пайки»): 
Small - малый (диаметр 20 mil); Large - большой (диаметр 30 mil); User - за-

даваемый пользователем (от 1 до 394 mil). 
На закладке Miscellaneous на поле ERC Errors выбираются параметры: 
Show - разрешение вывода на схему маркеров ошибок ERC; Hide - запрет 

вывода на схему маркеров ошибок ERC; No Change - запрет изменения на схеме 
маркеров ошибок ERC. 

На панели Cursor Style выбирают тип курсора: 
Arrow - стрелка; Small Cross - маленькое перекрестье; Large Cross - большое 

перекрестье. 
На панели Sheet Connector Cross Referencing устанавливаются параметры 

соединителей страниц. 
На панели Miscellaneous задают разнообразные параметры: 
Draft Mode - изображение контуров линий и полигонов; 
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Display Default PinDes - отображение на экране номеров выводов символов 
компонентов, заданных по умолчанию; 

Display Open Ends - отображение неподсоединенных выводов или цепей; 
Display Overridden Errors - отображение на экране перекрывающихся мар-

керов ошибок; 
Display Part Gate Number - отображение на экране номеров секций компо-

нентов; 
Scroll Bars - размещение на экране линий прокрутки; 
Show Data Tips - вывод подсказок на рабочем поле (они не выводятся при 

использовании курсора большого размера и при выполнении команды 
View>Snap to Grid); 

Thin Stroke Text - установка тонких линий векторных шрифтов; 
Drag by Outline - изображение символов компонентов линиями контура при 

их перемещении или копировании (для ускорения перечерчивания экрана). 
Нажатие клавиши Defaults назначает всем параметрам значения по умолча-

нию, OK - внесение изменений, Cancel - их отмена. 
В PCAD Schematic нет понятия слоев изображения, которые можно сделать 

видимыми или невидимыми. Вся информация располагается на одном слое, и с 
помощью меню Options > Display можно любую информацию, например атри-
буты компонентов (Part Attr), сделать невидимой — для этого ее нужно окрасить 
в цвет фона (Background). 

По командам Options > Current Wire и Options > Current Line определяют 
ширину цепей Wire (осуществляют электрические соединения) и Line (графиче-
ские линии не обеспечивают электрического соединения). 

В меню Options > Text Style выбирают стиль текста, устанавливаемый по 
умолчанию, и при необходимости редактируют стили выполнения отдельных 
надписей. В меню редактирования шрифта  выбирают тип шрифта: Stroke Font 
(векторные шрифты) или TrueType Font (контурные шрифты), имя шрифта 
(Font) и его размер. Все стили надписей сохраняются в файле схемы. 

Параметры настройки конфигурации программы PCAD Schematic заносятся 
в файл SCH.INI и сохраняются при последующей работе с ней. Кроме того, па-
раметры проекта (стили линий, стили шрифта и др.) заносятся в файл схемы. 
Поэтому целесообразно создать «шаблоны» пустых схем, например, в файлах 
template1.sch, template2.sch..., занося в них только параметры конфигурации 
(включая список шагов сетки, список стилей линии и т. п.), и загружать их перед 
началом создания новых схем. 

В PCAD имеется команда File>Design Technology Parameters для просмот-
ра и загрузки набора технологических требований к печатной плате (ПП). Тех-
нологические правила, относящиеся к определению классов цепей и правил их 
трассировки и трассировки отдельных цепей, вводятся по команде Op-
tion>Design Rules как в редакторе PCAD Schematic, так и в редакторе  
PCAD РСВ. Данные об апертурах, о наборе слоев ПП и стилях контактных пло-
щадок (КП) и переходных отверстий (ПО) можно модифицировать и ввести за-
ново только в PCAD РСВ. 
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2.1. Создание принципиальных схем 
После настройки конфигурации PCAD Schematic приступают к созданию 

принципиальной схемы по следующему алгоритму. 
1. Загрузка библиотек. Перед нанесением на схему символов компонентов 

по команде Library>Setup обеспечивается доступ к необходимым библиотекам 
(рис. 2.4, а). Нажав клавишу Add, добавляют имена библиотек в список откры-
тых библиотек (Open Libraries).  

 

 
а 

 
б 

Рис. 2.4. Загрузка библиотек (а) и выбор символа компонента (б) 
 
2. Размещение компонентов на схеме. В режим размещения символов 

компонентов на схеме переходят по команде Place>Part . После этого щелчок 
курсором в любой точке схемы открывает меню выбора компонента (рис. 2.4, б). 

На панели Library указывается имя одной из открытых библиотек, список 
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ее компонентов выводится в окне Component Name. 
Имя нужного компонента выбирают из этого списка или вводят в верхней 

строке. Нажатие клавиши Browse позволяет просмотреть графическое изо-
бражение символа компонента (справа на рис. 2.4, б). При создании символа 
компонента в графе Alternate можно задать несколько альтернативных вари-
антов. 
В графе Num Parts указывается общее число секций компонента (изменять 

их на этом этапе нельзя).  
В окне Part Num по умолчанию указывается номер секции 1, но при необ-

ходимости его можно изменить перед размещением символа компонента на схе-
ме. 

Нажатие клавиши Query активизирует средства поиска компонента в от-
крытых библиотеках. Сначала в диалоговом окне Query в столбцах Criteria зада-
ют критерии поиска и в столбце Show отмечают, какие характеристики найден-
ных компонентов нужно отображать в таблицах результатов поиска. 

Позиционные обозначения компонентов на схеме проставляются автомати-
чески. Для изменения назначенного в библиотеке префикса позиционного обо-
значения его надо указать в поле RefDes в явном виде (см. рис. 2.4, б). Для ком-
понентов, состоящих из одной секции, имя секции не проставляется. 

При изображении многосекционных компонентов совмещенным способом 
(изображения смежных секций примыкают друг к другу) позиционные обозна-
чения отдельных секций обычно не указываются, для этого необходимо пара-
метры RefDes всех секций, кроме первой, сделать невидимыми (выключить 
кнопку Visibility), тогда будет видно позиционное обозначение только первой 
секции.  

На строке Value проставляют номинал компонента, например сопротивле-
ние резистора. 

После выбора в меню Place>Part нужного компонента и введения всех не-
обходимых параметров нажимают OK — курсор примет форму перекрестья с 
разрывом в центре для точного позиционирования в узлах сетки. Непосредст-
венное размещение символа компонента на схеме выполняется после щелчка 
курсором в любой точке рабочего окна. До тех пор, пока не отпущена левая 
кнопка мыши, символ перемещается по экрану. Он поворачивается на 90° в на-
правлении против часовой стрелки и зеркально отображается нажатием клавиш 
R и F соответственно. Повторный щелчок курсором размещает на схеме очеред-
ную копию символа выбранного компонента, присваивая ему следующее пози-
ционное обозначение, которое одновременно выводится в строке информации. 
Для увеличения на единицу номера секции компонента перед размещением сим-
вола нажимают клавишу Р, а для увеличения позиционного обозначения — кла-
вишу D. Уменьшить эти значения можно одновременным нажатием клавиш 
Shift+P или Shift+D. Нажатие правой кнопки мыши или Esc прекращает ввод 
символов. 

В режиме Edit>Select щелчок курсора в любой точке внутри контура символа 
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компонента производит его выбор с возможностью перемещения, поворота и уда-
ления символа вместе с принадлежащими ему атрибутами. Нажатие клавиши 
Shift и удерживание ее до щелчка курсора позволяет выбрать отдельный эле-
мент символа: вывод, элемент графики, позиционное обозначение и др. 

3. Размещение электрических цепей. После выбора команды Place>Wire 
 курсор принимает форму перекрестья. Щелчком мыши отмечается начальная 

точка цепи. Каждое нажатие левой кнопки мыши фиксирует точку излома. На-
жатие клавиши О до отпускания левой кнопки мыши изменяет угол ввода линии 
из числа разрешенных (задаваемых в меню Options>Configure), нажатие клави-
ши F изменяет ее ориентацию. В связи с тем, что на схеме обычно преобладают 
горизонтальные или вертикальные цепи, в меню Options>Configure достаточно 
включить только режим ввода ортогональных цепей 90/90  
Line-Line. Завершается ввод цепи нажатием правой кнопки мыши (или Esc). 

Ширина прокладываемой цепи (рекомендуется 0,25 мм) устанавливается по 
команде Options>Current Wire: Thick — широкая (0,381 мм = 15 mil), Thin - уз-
кая (0,254 мм = 10 mil) и User - задаваемая пользователем (в пределах от 0,1 до 
100 mil). 

Неподсоединенные выводы компонентов и открытые концы цепей, не под-
соединенных к другим цепям или к выводам компонентов, помечаются квадра-
тиками, которые гаснут после выполнения электрического соединения. 

Если при перемещении цепи, имеющей присвоенное ей ранее имя (не сис-
темное имя типа NETxxxxx), она соприкоснулась с другой такой же цепью, от-
крывается диалоговое окно (рис. 2.5) для выбора имени объединенной цепи или 
отказа от выполнения операции. При одновременном соединении нескольких 
цепей (это возможно при их перемещении в окне) выводится сообщение об отка-
зе от  их объединения, что позволяет продолжить перемещение этих цепей или 
вернуться к исходному состоянию по команде Undo. 

 

 
Рис. 2.5. Выбор имени соприкасающихся цепей 

 

Включение в цепь дополнительной точки излома для последующего редак-
тирования выполняется по команде Rewire>Manual . 

В строке информации выводится присваиваемое автоматически имя разме-
щаемой цепи, например Net: NET00003. Следующая цепь получит имя 
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NET00004. 
Присвоить цепи другое имя можно двумя способами.  
I. Индивидуально выбрать каждую цепь и щелчком правой кнопки мыши 

открыть в меню редактирования пункт Properties и изменить имя цепи, заменив 
на строке Net Name назначенное системой имя другим, например заменить 
NET00001 на А1. Это имя будет видимым, если включить на закладке Wire пере-
ключатель Display.  

II. С помощью команды Utils>Rename Nets в открывшемся меню на строке 
Net Name ввести префикс имени и выбрать параметр Increment Name (режим 
приращения имени). После закрытия этого меню щелчком курсора по первой 
цепи ей присваивается имя Pref 0, по второй - Pref 1 и т. д. Чтобы начать нуме-
рацию цепей не с нуля, нужно начальное имя ввести в явном виде, например 
DATA5. Тогда первая цепь получит имя DATA5, вторая - DATA6 и т. д. 

Если к цепи подсоединить компонент заземления GND, то она автоматиче-
ски получит имя GND, так как выводу компонента заземления присвоен тип 
Power, что обеспечивает автоматическую замену имени цепи, к которому он 
подключен, на имя этого компонента. 

Электрическое соединение пересекающихся цепей обозначается точкой 
«пайки» (Junction), которая автоматически проставляется на Т-образных соеди-
нениях. 

Чтобы проставить точку соединения пересекающихся цепей, нужно при 
вводе второй цепи щелкнуть курсором в точке пересечения и затем продолжить 
ее построение. 

4. Размещение шин. Выбор команды Place>Bus  активизирует режим 
ввода шин. Щелчком курсора отмечают начало шины и точки ее излома. По-
строение шины завершается нажатием правой кнопки мыши или Esc. 

После этого по команде Place>Wire размещают цепи. При рисовании цепи, 
входящей в состав шины, ее начало или конец должны располагаться в любой 
точке шины. При этом при подключении к шине автоматически изображается 
излом цепи под углом 45° (стиль этого изображения устанавливают в меню ко-
манды Options>Display (см. рис. 2.3, а). Шина изображается на схеме линией 
шириной 0,76 мм и изменить ее ширину нельзя. При необходимости можно по-
верх нее нарисовать линию нужной ширины по команде Place>Line. 

Имена цепей, образующих шину, задаются подключением к цепям по ко-
манде Place>Port  специальных портов. После выбора команды Place>Port 
щелчком мыши на любой точке схемы открывается изображенное на рис. 2.6, а 
меню выбора порта. На расположенной вверху строке Net Name указывают имя 
первой цепи, например D1. Если включить переключатель Increment Port Name, 
то при размещении портов они автоматически получат имена D1, D2, D3 и т. п.  

Для обозначения цепей в шине в соответствии с ЕСКД необходимо выбрать 
тип порта без рамки (None) с одним выводом (One pin) и располагать его верти-
кально (Vertical). В результате имя цепи (порта) будет расположено над ней. По-
сле закрытия меню нажатием ОК порты подключаются последовательными 
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щелчками мыши по именуемым цепям (текущее имя цепи отображается в строке 
информации). Именованные таким образом цепи являются глобальными 
(Global), их можно переименовывать по командам Edit>Nets и 
Utils>Rename Nets. Видимость имени шины устанавливается с помощью пере-
ключателя Display меню Bus Properties (рис. 2.6, б). 

 

 
а 

 
б 

Рис.  2.6. Диалоговые окна команд Place>Port (а) и Bus Properties (б) 
 

5. Размещение проекта на нескольких листах. Для создания дополни-
тельных листов схемы по команде Options>Sheets на закладке Sheets в поле 
Sheet Name последовательно определяют имена второго и последующих листов 
схемы, каждый раз нажимая кнопку Add. Наиболее естественно именовать лис-
ты схемы Sheet1, Sheet2 и т. д. (при этом все листы находятся в одном файле). В 
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дальнейшем листы схемы переключаются в строке состояний.  
Перед переносом части схемы на другой лист необходимо к выводу компо-

нента, связь от которого должна быть проложена на другой лист, подключить 
порт, имеющий один вывод (соединитель страниц), и присвоить ему имя цепи 
(рис. 2.7). На другой странице должен быть размещен порт с тем же именем для 
обеспечения электрического соединения. 

 
Рис. 2.7. Соединитель страниц 

 
6. Добавление атрибутов цепей и компонентов. Для добавления атрибута 

цепи (или компонента) выбирается цепь (или компонент) и после открытия 
щелчком правой кнопки мыши меню редактирования указывают в нем пункт 
Properties. Затем по команде Add добавляют атрибуты, как показано на рис. 2.8, 
где введен атрибут ширины проводника Width, который будет принят во внима-
ние автотрассировщиком. С помощью выключателя Visible каждый атрибут мо-
жет быть сделан видимым или невидимым на схеме. Для управления видимо-
стью на экране всех однотипных атрибутов по команде Option>Display атрибу-
ту можно назначить индивидуальный цвет или цвет фона (чтобы он был не ви-
ден). Аналогично при выводе схемы на печать по команде 
File>Print>Print Options указывают цвета атрибутов и других объектов. Таким 
образом назначают цепям или компонентам индивидуальные атрибуты. Атрибу-
ты общего характера вводят по команде Place>Attribute. 

7. Поиск объектов. Выберем компонент и щелчком правой кнопкой мыши 
развернем всплывающее меню, в котором укажем команду Highlight Attached 
Nets — в результате высвечиваются все цепи, подключенные к этому компонен-
ту. Для поиска на схеме компонента выполняют команду Edit>Parts и в от-
крывшемся меню со списком всех компонентов курсором указывают имя кон-
кретного компонента. После нажатия на кнопку Jump этот компонент ярко вы-
свечивается, даже если он находится на другом листе схемы (листы схемы пере-
ключаются автоматически). Аналогичную процедуру выполняют при выборе 
цепи в меню команды Edit>Nets (рис. 2.9).  

В списке цепей можно вывести имена всех цепей (All Nets) или только гло-
бальных цепей (Global Nets Only), а также имена шин (Bus). По команде Jump to 
Node курсор указывает на схеме узел данной цепи, предварительно выбранный в 
списке Nodes, в котором приняты обозначения: U3-1 - это вывод 1 компонента 
U3. 
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Рис. 2.8. Редактирование атрибутов цепей 

 

 
Рис. 2.9. Меню выбора цепей 

 
8. Редактирование схемы. Для перемещения компонента или цепи необходимо 
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выбрать их щелчком курсора и затем перемещать движением мыши. Если после 
перемещения сегментов цепей часть из них будет расположена неаккуратно, 
щелчком курсора выбирают отдельный сегмент и перемещают его вершину. 
Выбор для редактирования элемента сложного объекта (например, позиционно-
го обозначения компонента) производится щелчком левой клавиши мыши при 
одновременном нажатии кнопки Shift. 

Перед перемещением группы объектов полезно щелчком правой кнопкой 
мыши выбрать команду Select Point для нанесения точки привязки (имеет форму 
перекрестья, заключенного в квадрат). При перемещении объектов в строке ин-
формации выводятся значения смещения точки привязки dX, dY относительно 
ее первоначального расположения. 

Скопировать выделенную группу объектов можно удерживанием клавиши 
Alt при перемещении мыши. При этом входящие в группу глобальные цепи не 
изменяют своих имен (к глобальным относятся цепи, к которым подключены 
порты или выводы компонентов, имеющие тип Power), остальные цепи пере-
именовываются. Компонентам присваиваются новые позиционные обозначения. 
После размещения символов нескольких одинаковых компонентов всем им сра-
зу можно присвоить одинаковые атрибуты.  

9. Изменение позиционных обозначений. Перед завершением создания 
схемы целесообразно переименовать позиционные обозначения компонентов 
согласно ЕСКД вручную или с помощью специальной утилиты DBX. При пере-
нумерации позиционных обозначений по команде Utils>Renumber невозможно 
соблюдать требования ЕСКД.  

10. Сохранение проекта. По команде File>Save отредактированный проект 
сохраняется в исходном файле, по команде File>Save As проект сохраняется в 
другом файле, причем предварительно можно выбрать его формат: 

Binary Files - бинарный формат (расширение имени *.SCH); 
ASCII Files - текстовый формат (расширение имени *.SCH).  
Файлы обоих форматов имеют одно и то же расширение имени *.SCH. Би-

нарный формат более компактен и является основным, текстовый формат ис-
пользуют для обмена данными с другими программами. 

В файле схемы хранятся следующие параметры: система единиц; набор ша-
гов сетки; стили текста; шаблоны отчетов. 

Чтобы не вводить эти данные всякий раз для каждой новой схемы, реко-
мендуется завести один или несколько отдельных файлов, не имеющих графиче-
ской информации, ввести типичные параметры и сохранить эти шаблоны схем 
под уникальными именами, например TEMPLATE_1.SCH и т.п.  

Иерархические структуры. PCAD Schematic поддерживает иерархические 
или модульные структуры, что удобно для изображения принципиальных схем, 
состоящих из однотипных элементов, и для упрощения изображения сложных 
схем. На верхнем уровне иерархии помещается изображение модуля в виде пря-
моугольного «черного ящика», а его принципиальная схема размещается на бо-
лее низком уровне иерархии (схемы всех уровней иерархии записываются на 
разных листах одного и того же проекта). Модуль представляется в виде компо-
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нента, имя которого (Module name) задает пользователь. Модуль имеет выводы 
(Pin), к которым подключают внешние цепи. Связь между изображением модуля 
и его принципиальной схемой осуществляется с помощью понятия Link. Ин-
формация об этой связи (т. е. о схеме модуля) представляется в виде отдельного 
компонента, имя которого (Link name) также задает  
пользователь. Модуль иерархической структуры создают по команде 
Utils>Module Wizard. После размещения на схеме символов модулей необхо-
димо выполнить команду Utils>Resolve Hierarchy для простановки сквозных 
позиционных обозначений компонентов и именования цепей проекта с учетом 
схем, входящих в него иерархических структур. Эта команда должна выполнять-
ся перед корректировкой схемы ЕСО и составлением списка электрических свя-
зей (поэтому, в частности, при «упаковке» схемы на ПП на нее переносятся и 
компоненты, входящие в состав иерархических структур). 

 
2.2. Проверка схем с помощью утилиты ERC 

После создания принципиальной электрической схемы целесообразно вы-
явить синтаксические ошибки, исправить их и только после этого перейти к раз-
работке ПП. Проверку схемы выполняют по команде Utils>ERC (Electrical Rules 
Check). В основном меню этой команды задают перечень проверок, результаты 
которых приводятся в текстовом отчете: 

Single Node Nets - цепи, имеющие единственный узел; 
No Node Nets - цепи, не имеющие узлов; 
Electrical Rules - электрические ошибки, когда соединяются выводы несо-

вместимых типов (например, соединяются два выходных вывода или выходной 
вывод подключается к выводу источника питания); 

Unconnected Pins - неподключенные выводы компонентов; 
Unconnected Wires - неподключенные (плавающие) цепи; 
Bus/Net Errors - входящие в состав шины цепи, встречающиеся только один 

раз (т. е. они входят в шины, но не выходят из них); 
Component Rules - компоненты, расположенные поверх других компонен-

тов; 
Net Connectivity Rules - неправильное подключение цепей земли и питания; 
Hierarchy Rules - ошибки иерархической структуры. 
Степень серьезности отдельных ошибок (Error, Warning или Ignored) на-

значается в диалоговом окне, открываемом после нажатия на панель Severity 
Level. Там же необходимо включить опции View Report (Просмотр отчета сооб-
щений об ошибках) и Annotate Errors (Индикация ошибок на схеме). 

Сообщения об ошибках заносятся в файл <имя схемы>.ЕRС, изменение 
этого имени производят после выбора панели Filename. 

Поиск ошибок в соответствии с заданной конфигурацией начинается после 
нажатия панели ОК. Информация об ошибках помечается на схеме индикатора-
ми и выводится в текстовый отчет. 

Координаты ошибок приводятся в той системе единиц, которая выбрана в 
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меню команды Options>Configure. 
 

2.3. Вывод данных 
Результаты проектирования выводятся в PCAD Schematic в виде: 
− схемы, напечатанной на принтере или плоттере; 
− списка соединений схемы (в частности, для упаковки схемы на ПП или 

выполнения моделирования);  
− текстовых отчетов. 
Вывод схемы на печать. Для подготовки к печати электрической схемы на 

принтере или плоттере выполняют команду File>Print Setup и в развернувшем-
ся меню выбирают тип устройства вывода, предварительно установленного 
средствами Windows. Нажатием панели Setup открывают меню выбора размера 
и ориентации бумаги, характера передачи полутонов, разрешающей способно-
сти, качества печати (высокое, черновое). На строке Minimum Line Width for 
printing (pixels) устанавливают минимальную ширину прямых линий в пикселях 
(на дуги это не распространяется). При подготовке к печати указывается также 
масштабный фактор и поворот чертежа на 90 0, если необходимо.  

Непосредственный вывод на печать выбранных листов начинается после 
нажатия клавиши Generate Printouts, предварительный просмотр - после нажа-
тия клавиши Print Preview. 

Создание списка соединений. Список соединений включает в себя список 
компонентов и цепей с указанием номеров выводов компонентов, к которым они 
подключены. Он используется для так называемой процедуры «упаковки схемы 
на печатную плату» - размещения на поле ПП корпусов компонентов с указа-
нием их электрических связей согласно принципиальной схеме. Для создания 
списка соединений необходимо по команде Utils>Generate Netlist открыть меню 
настройки параметров и в пункте меню Netlist Format выбирать формат списка 
соединений: PCAD ASCII, Tango, FutureNet Netlist, FutureNet Pinlist, Master De-
signer, EDIF 2.0.0, PSpice, XSpice.  

Для разработки ПП с помощью графического редактора PCAD PCB реко-
мендуется выбирать формат Tango или PCAD ASCII (последний передает атри-
буты схем на ПП). Имя файла списка соединений задают после нажатия клави-
ши Netlist Filename. 

Нажатием кнопки Include Library Information включают в файл списка со-
единений (только для формата PCAD ASCII) информацию, необходимую для 
составления с помощью Library Manager библиотеки символов компонентов, 
находящихся в данной схеме (по команде Library>Translate).  

Составление отчетов. По команде File>Reports создают текстовые отчеты 
о схеме. Дополнительно выбирается содержание и форма отчета, а также уст-
ройство вывода: консоль, принтер или файл. С помощью отчета удобно анали-
зировать спроектированную схему и контролировать ошибки, внесенные опера-
тором при создании библиотечных компонентов и вводе информации. 
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3. Порядок выполнения работы 
1. Изучить теоретический материал. 
2. Получить индивидуальное задание у преподавателя согласно варианту 

(приложение). 
3. Подключить к проекту необходимые библиотеки и создать схему элек-

трическую принципиальную устройства. 
4. Проверить разработанную схему с помощью утилиты Electrical Rules 

Check. 
5. Сгенерировать список соединений разработанной схемы для последую-

щего проектирования печатной платы в PCAD PCB. 
6. Получить распечатку результатов выполнения работы. 
7. Оформить отчет по лабораторной работе. 
 

4. Содержание отчета 
1. Цель работы. 
2. Результаты выполнения работы в виде таблиц текстового отчета о схеме 

и разработанной схемы электрической принципиальной. 
3. Электронные версии схемы электрической принципиальной и списка со-

единений. 
4. Выводы по работе. 
 

5. Контрольные вопросы 
1. Назначение графического редактора PCAD Schematic. 
2. Алгоритм создания принципиальной схемы электрической. 
3. Каковы функции утилиты Electrical Rules Check? 
4. Какими способами можно переименовать цепи и шины в проекте? 
5. Особенности размещения проекта на нескольких листах. 
6. Что такое иерархическая структура в PCAD Schematic?  
7. Организация поиска объектов в PCAD Schematic. 
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Лабораторная работа № 3 
 
ПРОЕКТИРОВАНИЕ ПЕЧАТНОЙ ПЛАТЫ В РСВ PCAD 2001 

 
1. Цель работы 

Изучить способы проектирования печатных плат в PCB PCAD. Изучить ме-
тоды и программы трассировки печатных проводников. Отработать навыков ра-
боты с системой автоматической трассировки печатных проводников САПР 
PCAD 2001. 

 
2. Краткие теоретические сведения 

Для размещения компонентов на печатной плате и ручной трассировки в 
САПР PCAD используется графический редактор РСВ. 

Построен редактор печатных плат так же, как и редактор схем - отличие 
лишь в объектах, с которыми он работает. Поэтому на инструментальных пане-
лях редактора имеются новые кнопки, а в меню - новые команды, необходимые 
для создания печатных плат. PCAD PCB в отличие от PCAD SHEMATIC под-
держивает многослойную организацию проекта. 

 
2.1. Настройка конфигурации PCAD PCB 

Перед началом работы в PCAD PCB необходимо настроить его конфигура-
цию по команде Options>Configure. Настройки PCAD PCB в основном совпа-
дают с настройками редактора PCAD SHEMATIC. Дополнительно в графе 
Workspace Size указывают размеры рабочей области, немного превышающие 
габаритные размеры ПП (по умолчанию устанавливается 254х254 мм, макси-
мальные размеры ПП 60х60 дюймов или 1524х1524 мм). 

На закладке Route отмечают опцию T-Route by Default для разрешения об-
разования Т-образных соединений проводников, в графе Orthogonal Modes 
включают все режимы (остальные параметры принимают значения по умолча-
нию, их настраивают позже по мере надобности). 

На закладке Manufacturing  задают значения глобальных технологических 
параметров: отступы масок пайки, зазоры между областью металлизации, на-
правление пайки волной припоя и т.п. 

При создании новой ПП по умолчанию устанавливаются 11 стандартных 
слоев: 

Тор - верхняя сторона ПП; 
Bottom - нижняя сторона ПП; 
Board - контур ПП; 
Top Mask - маска пайки на верхней стороне ПП; 
Bot Mask - маска пайки на нижней стороне ПП; 
Top Silk - шелкография на верхней стороне ПП (контуры компонентов и 

т.п.); 
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Bot Silk - шелкография на нижней стороне ПП; 
Top Paste - маска для паяльной пасты на верхней стороне ПП; 
Bot Paste - маска для паяльной пасты на нижней стороне ПП; 
Top Assy - вспомогательные данные на верхней стороне ПП; 
Bot Assy - вспомогательные данные на нижней стороне ПП.  
Слои Тор и Bottom, Top Silk и Bot Silk и т.п. являются парными. Понятие 

парности слоев используется при переносе компонента на другую сторону ПП 
нажатием на клавишу F (Flip - зеркальное отображение), при этом вся графиче-
ская и текстовая информация переносится на ответствующие парные слои (при 
зеркальном отображении простых графических объектов - линий, полигонов и т. 
п. - они остаются на первоначальном слое). 

Всего в PCAD PCB может быть до 99 слоев. Слои создают и удаляют по 
команде Options Layers. Выделяют три типа слоев: 

Signal - слои разводки проводников сигналов, помечают символом S; 
Plane - слой металлизации для подключения цепей «земли» и «питания», 

помечают символом Р; 
Non Signal - вспомогательные слои, помечают символом N. 
Каждый слой может быть включен (Enable, символ Е) или выключен (Dis-

able, символ D).  
В графе Routing Bias указывают приоритетную ориентацию проводников 

на каждом слое при автоматической трассировке: 
Auto - выбирается автоматически, символ А;  
Horizontal - горизонтальная, символ Н;  
Vertical - вертикальная, символ V. 
Удалять можно только слои, введенные пользователем, не являющиеся те-

кущими и на которых не содержится информация; стандартные слои удалять 
нельзя. 

Список значений ширины трасс проводников и геометрических линий со-
ставляется по команде Options>Current Line. 

По команде Options>Pad Style открывают список стеков КП, по команде 
Options>Vie Style - список стеков ПО. Выбранные курсором в этих списках сте-
ки являются текущими и помещаются на ПП при выполнении команд 
Place>Pad, Place>Vie. Нажатием на панель Modify открывают меню редактиро-
вания стеков КП (рис. 3.1). 

В PCAD PCB  выделяют два вида стеков контактных площадок: 
1) простые (Simple) - выводы штыревых компонентов, имеющие одинако-

вую форму КП на всех слоях, и планарных компонентов, имеющие КП только на 
одном слое; 

2) сложные (Complex) - имеют различные КП на нескольких слоях.  
Для стеков КП планарных компонентов задаются их геометрические разме-

ры на том слое (Тор или Bottom), на котором наносится графика корпуса (при 
последующей пайке планарных компонентов волной припоя их стеки КП необ-
ходимо размещать на слое Bottom). 
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Рис. 3.1. Редактирование планарного стека 

 
Перед размещением на ПП компонентов вручную или с помощью процеду-

ры упаковки принципиальной схемы необходимо обеспечить доступ к библио-
текам, в которых находятся эти компоненты. Библиотеки подключают по коман-
де Library>Setup.  

 
2.2. Разработка печатных плат в PCAD PCB 

Разработку новой ПП начинают с выполнения команды File>New и на-
стройки конфигурации или загрузки шаблона. Затем на слое Board по команде 
Place>Line наносится контур ПП в виде замкнутой линейно-ломаной линии (ду-
ги не разрешаются). 

1. Упаковка схемы на печатную плату. При отсутствии принципиальной 
схемы проекта компоненты расставляют на ПП по команде Place>Component и 
по команде Place>Connection вводят электрические связи между их выводами. 
При наличии принципиальной схемы для переноса (упаковки) ее на ПП по ко-
манде Utils>Load Netlist загружают файл списка соединений (который создается 
в редакторе PCAD Schematic в форматах Tango или PCAD ASCII). 

Обычно схема упаковывается на ПП, на которой предварительно разме-
щены: разъемы; крепежные отверстия; другие компоненты, имеющие фиксиро-
ванное положение (в диалоговом окне Properties этих компонентов необходимо 
отметить опцию Fixed), и проложен ряд трасс.  

В этом случае после загрузки команды Utils>Load Netlist выводится сооб-
щение, информирующее о необходимости соблюдения следующих ограничений: 

— компоненты с совпадающими на ПП и на схеме позиционными обозна-
чениями (RefDes) должны иметь одинаковые типы корпуса (Type). При обнару-
жении конфликтов упаковка не производится; 

— все присутствующие на ПП компоненты, не входящие в список соедине-
ний, будут сохранены; 

— на ПП переносятся все компоненты из списка соединений, которые не 
установлены на ней предварительно; 

—электрические связи, проложенные предварительно на ПП и отсутствую-
щие в списке соединений, удаляются (обновляется вся информация об электри-
ческих связях), однако все проложенные ранее проводники сохраняются, даже 
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если они отсутствуют в списке соединений; 
— после выполнения команды нельзя восстановить первоначальный вид 

ПП с предварительно размещенными компонентами, поэтому ее рекомендуется 
сохранить в отдельном файле. 

2. Размещение компонентов на плате. После загрузки списка соединений 
(упаковки схемы) на ПП приступают к размещению компонентов внутри конту-
ра ПП (если он есть). Размещение компонентов на ПП обычно производят вруч-
ную. Линии электрических связей, перемещаемые вместе с компонентами, по-
могают правильно их разместить. 

Нажатием клавиши R поворачиваем выбранный объект против часовой 
стрелки на 90°, одновременным нажатием Shift+R поворачиваем его на угол, за-
данный в меню Options>Configure на закладке General (параметр Rotation In-
crement), нажатием клавиши F зеркально отображаем объекты относительно оси 
Y и переносим компоненты на противоположную сторону ПП. 

При размещении однотипных компонентов удобно их автоматически вы-
равнивать. Для этого выравниваемые компоненты по очереди выбираются 
щелчком курсора (при выборе второго и последующих компонентов нажимают 
и удерживают клавишу Ctrl). Затем выбирают опцию Align (Выравнивание) и в 
открывшемся меню отмечают способ выравнивания. 

После завершения размещения компонентов полезно выполнить минимиза-
цию длин соединений путем перестановки логически эквивалентных секций 
компонентов и их выводов по команде Utils>Optimize Nets (перестановка воз-
можна, если в ней не участвуют уже проложенные проводники). 

3. Задание правил проектирования. Перед началом трассировки в меню 
Options>Grids задают необходимый шаг сетки.  

Затем по команде Options>Design Rules на закладке Layers устанавливают 
допустимые зазоры для каждого слоя трассировки (рис. 3.2). 

 
Рис. 3.2. Пример задания правил и ограничений трассировки 

 

Перед началом ручной трассировки целесообразно включить режим теку-
щей проверки допустимых зазоров, пометив на закладке Online DRC команды 
Options>Configure строку Enable Online DRC. 

Для управления размещением компонентов и трассировки соединений в ав-
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томатическом или интерактивном режиме и проверки DRC цепям и компонен-
там присваивают атрибуты по команде Edit>Nets. 

4. Барьеры трассировки. Графический редактор PCAD РСВ имеет воз-
можность создавать на ПП барьеры трассировки. Расположение на ПП по ко-
манде Р1асе>Keepout сегмента линии или замкнутой области в виде полигона 
запрещает Quick Route пересекать их трассами проводников на одном выбран-
ном или на всех доступных слоях (места размещения крепежных отверстий, за-
прещенные для трассировки по конструкционным соображениям области и т.п.). 
Предварительно по команде Options>Current Keepout устанавливают парамет-
ров барьеров трассировки: линия (Line) или полигон (Polygon), располагаемые 
на текущем (Current) или на всех доступных слоях (All). 

Контур ПП, рисуемый на слое Board по команде Place>Line, воспринимает-
ся Quick Route как барьер, который нельзя пересекать проводниками на всех 
слоях. Поэтому трассы будут проведены как внутри этого контура, так и вне его 
(но не пересекая). 

5. Ручная трассировка соединений. Перед началом трассировки какого-
нибудь проводника задают его ширину и выбирают нужный слой. Трассу про-
водника можно начать только от тех КП, которые имеют электрические связи. 
При необходимости электрические связи устанавливают вручную по команде 
Р1аce>Connection. 

Ручную трассировку проводников выполняют по команде Route>Manual.  
Для облегчения создания Т-образного соединения трасс выполняют его при 

нажатой клавише Shift или заранее на закладке Route диалогового окна команды 
Options>Configure включают опцию T-Route by Default. 

При смене в процессе прокладки трассы текущего слоя нажатием клавиш L, 
Shift+L или с помощью строки состояний трасса продолжается на другом слое, 
при этом автоматически вставляется ПО текущего типа (заданного заранее по 
команде Options>Via Style). 

Не прерывая прокладку трассы, можно изменить ширину проводника по 
команде Options>Current Line или с помощью строки состояний. 

Нарушение зазора между трассой проводника и выводом компонента, ПО 
или трассой другой цепи отмечается индикаторами ошибок в виде круга с пере-
крестием, если включен режим Online DRC. 

Нажатие правой кнопки мыши или выбор любой команды завершает трас-
сировку проводника по кратчайшему расстоянию до контактной площадки вы-
вода компонента. Нажатием косой черты «/» или «\» прекращают прокладку 
трассы без ее завершения. 

Завершение трассы точно на контактной площадке пункта назначения обо-
значается ромбом с перекрестьем. 

В процессе трассировки полезно обращать внимание на строку информа-
ции, в которой выводятся следующие данные: 

— приращения координат dX, dY каждого сегмента, пока нажата левая 
кнопка мыши; 

— общая длина трассы до точки излома Total length (с учетом длин дуг); 
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— число ошибок при прокладке трассы «<n> error(s) during routing» (выво-
дится после ее завершения). 

6. Интерактивная трассировка соединений. Трассу прокладывают по ко-
манде Route>Interactive движением курсора при нажатой левой кнопке, при 
этом автоматически огибаются препятствия (проводники, КП, ПО и области ме-
таллизации), соблюдаются допустимые зазоры. Нажатием правой кнопки мыши 
в процессе прокладки трассы открывают следующее меню: 

Complete - завершение прокладки трассы (если это возможно) с соблюдени-
ем установленного ранее режима ввода проводников (ортогонально или по диа-
гонали) и допустимых зазоров; 

Push Traces  - включение режима отталкивания мешающих проводников; 
Suspend - прекращение прокладки трассы с сохранением проложенного уча-

стка; 
Cansel - прекращение прокладки трассы с отменой ввода последнего сег-

мента (аналог нажатия клавиши Esc); 
Options — изменение параметров конфигурации проекта по команде  

Options>Configure; 
Layers — открытие окна команды Options>Layers для изменения структу-

ры слоев платы; 
Via Style — открытие окна Options>Via Style для выбора типа ПО или его 

редактирования; 
Unwind — отмена прокладки последнего сегмента проводника (аналог на-

жатия клавиши Backspace). 
Клавиши О, F, «/», «\» и стрелки имеют такие же назначения, как и при 

ручной прокладке трасс. Единственное отличие — не производится скругление 
трасс по дуге.  

Когда в процессе прокладки трассы левую кнопку мыши отпускают в точке 
окончания линии электрической связи, прокладка трассы завершается и можно 
переходить к прокладке следующей. 

7. Сглаживание прямоугольных изгибов проводников. Прямоугольные 
изгибы проводников скашиваются под углом 45° или сглаживаются дугами по 
команде Route>Miter. Режим сглаживания устанавливают на панели Miter 
Mode закладки Route команды Options>Configure. Сглаживание начинают 
щелчком курсора в точке излома трассы, не отпуская левую клавишу мыши, пе-
ремещают курсор и устанавливают необходимые размеры изгиба трассы. 

По завершении ручной трассировки проводников полезно выполнить ко-
манду Utils>Trace Clean-up для удаления наложенных друг на друга сегментов 
трасс и лишних точек излома. 

8. Области металлизации. На слоях сигналов могут располагаться области 
металлизации, электрически подсоединяемые к одной из цепей и автоматически 
отделяемые зазорами от других цепей и КП. Эти области создают в два этапа: 

1) по команде Place>Copper Pour рисуют внешний контур области  
металлизации в виде полигона (пересечения сторон полигона не допускаются); 

2) область выбирают щелчком курсора, в выпадающем меню выбирают 
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строку Properties и затем на закладке Connectivity открывшегося меню Copper 
Pour Properties указывают имя цепи, к которой она должна быть подключена. 
Здесь же выбирают необходимость использования КП с тепловыми барьерами 
(Thennals) или непосредственного соединения (Direct Connection) и задают 
ширину теплового барьера. После этого на закладке Style указывают особенно-
сти выполнения металлизации. 

При прокладке проводников через область металлизации зазоры образуются 
автоматически, если на закладке General команды Options>Configure включена 
опция Auto Plow Copper Pours. 

9. Сохранение проекта. По команде File>Save либо File>Save As отредак-
тированный проект сохраняется в файле, причем предварительно можно вы-
брать его формат. 

10. Проверка печатной платы с помощью утилиты DRC. Перед завер-
шением разработки ПП и выпуском фотошаблонов необходимо по команде 
Utils>DRC (Design Rule Checking) проверить ПП на соответствие принципиаль-
ной схеме и проверить соблюдение технологических ограничений. В меню этой 
команды выбирают различные правила проверок. 

После выполнения проверок перечень ошибок заносится в файл с расшире-
нием имени *.DRC. Включение опции Annotate Errors помечает на ПП места 
ошибок специальными индикаторами. После исправления ошибки ее индикатор 
автоматически удаляется. 

 
2.3. Вывод данных 

Результаты разработки ПП выводят на принтеры и плоттеры различных ти-
пов, используя средства Windows. В меню команды FiIe>Print в поле  
Minimum Line Width (pixels) устанавливают минимальную ширину линий, за-
тем нажимают кнопку Setup Print Jobs и переходят в меню составления зада-
ний. В этом меню сначала каждому заданию в графе Print Name присваивают 
имя. Затем в списке слоев Layers указывают нужные (второй и последующие 
слои выбирают щелчком курсора при нажатой кнопке Ctrl). 

В заключение устанавливают опции печати: 
Scale — масштаб изображения; 
Х и Y offset — смещение изображения по горизонтали и вертикали от края 

бумаги; 
Drill Symbols Size — размер символов отверстий; 
Rotate — поворот изображения на 90° по часовой стрелке; 
Mirror — зеркальное отображение; 
Draft — вывод контуров линий; 
Thin Striked Text — изображение векторных шрифтов тонкими линиями; 
RefDes, Type, Value, Pads, Vias, Pad/Via Holes, Pick and Place, Glue Dot, Test 

Point, Keepout, Cutout, Connections, Mt Hole, Titles - печать соответствующих объ-
ектов. 

Нажатие на кнопку Print Preview позволяет просмотреть изображение, пе-
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чать производится после нажатия на кнопку Generate Printouts. 
Создание и просмотр Gerber-файлов. PCAD РСВ обеспечивает создание 

управляющих файлов в стандартном формате фотоплоттера Gerber по команде 
File>Export>Gerber и загрузку изображения фотошаблона для контроля ошибок 
по команде File>Import>Gerber. 

Вывод информации для сверления отверстий. По команде 
File>Export>N/C Drill из базы данных спроектированной ПП извлекается ин-
формация о координатах отверстий и создается текстовый управляющий файл в 
формате станка с ЧПУ типа Excellon (аббревиатура N/C означает Numerically 
Controlled — числовое программное управление (ЧПУ)). 

Составление списков соединений. Список соединений включает в себя 
список компонентов и цепей с указанием номеров выводов компонентов, к кото-
рым они подключены. Изолированные области металлизации, а также неподсое-
диненные выводы компонентов в этот список не заносятся. 

По команде Utils>Generate Netlist открывается меню настройки парамет-
ров. В пункте меню Netlist Format выбирают формат списка соединений: PCAD 
ASCII или Tango. Нажатием кнопки Include Library Information включают в 
файл списка соединений (только для формата Р-CAD ASCII) информацию, не-
обходимую для составления с помощью Library библиотеки корпусов компонен-
тов, находящихся в данном проекте (по команде Library>Translate). 

По команде FiIe>Reports создают текстовые отчеты о ПП. 
 

2.4. Программа автоматической трассировки Quick Route 
Программа автотрассировки Quick Route (файл QROUTE.EXE) поставляет-

ся совместно с PCAD РСВ. Вызывают Quick Route из управляющей оболочки 
PCAD РСВ по команде Route>Autorouters (рис. 3.3) из списка: 

Quick Route – трассировщик Quick Route; 
PCAD Shape Route – трассировщик бессеточного типа, использующий алго-

ритмы оптимизации нейронных структур; 
SPECCTRA – программа SPECCTRA в режиме трассировки.  
Из этих программ Quick Route является наиболее простым трассировщиком, 

он пригоден для быстрой разработки не очень сложных ПП. 
Подготовка к трассировке. Quick Route трассирует текущую ПП, загру-

женную в PCAD РСВ. На ней должны быть размещены все компоненты и указа-
ны электрические связи между выводами. Предварительно на ПП можно размес-
тить барьеры трассировки Keepout и некоторые проводники. Quick Route не из-
меняет предварительно размещенные проводники и не прокладывает трассы за-
ново по более короткому пути. 

Характер меню настройки стратегии трассировки зависит от выбранного 
типа трассировщика. 
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Рис. 3.3. Выбор автотрассировщика Quick Route 

 
В меню Quick Route (см. рис. 3.3) в нижней части экрана расположены сле-

дующие кнопки: 
Layers – конфигурация слоев. Quick Route поддерживает до четырех слоев 

металлизации; 
Net Attrs – редактирование атрибутов цепей; 
Passes – выбор проходов трассировки; 
Via Style – выбор типа ПО. 
На строке Line Width выбирают ширину проводника от 0,1 mil (0,01 мм) до 

некоторого значения, зависящего от выбранного шага сетки. Например, для шага 
сетки 25 mil оно составляет 12 mil в английской системе или 0,305 мм в метри-
ческой системе, не более. Ширину индивидуального проводника назначают с 
помощью атрибута WIDTH, который может принимать любое значение. 

В меню редактирования стратегии трассировки Pass Selection выбирают 
типы проходов трассировки, выполняемых в следующем порядке: 

Wide Line Routing – разводка всех широких цепей, имеющих атрибуты 
ALITOROUTEWIDE и WIDTH перед выполнением других проходов. На этом 
проходе прокладывают только горизонтальные и вертикальные трассы. Наклон-
ные широкие трассы приходится прокладывать предварительно вручную – Quick 
Route их ширину не изменит; 

Horizontal – выполнение простейших соединений по горизонтали на любом 
слое без использования ПО и с минимальным отклонением от прямых линий; 

Vertical – выполнение простейших соединений по вертикали на любом слое 
без использовании ПО и с минимальным отклонением от прямых линий; 

'L' Routes (1 via) – формирование пересечения двух проводников и одного 
ПО, имеющего форму буквы L. Проводники располагаются на двух активных 
слоях и имеют противоположную ориентацию (горизонтальную или вертикаль-
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ную); 
'Z' Routes (2 vias) – формирование пересечения трех проводников и двух 

ПО, имеющего форму буквы Z. Проводники располагаются на двух активных 
слоях и имеют противоположную ориентацию (горизонтальную или вертикаль-
ную); 

'С' Routes (2 vias) – формирование пересечения трех проводников и двух 
ПО, имеющего форму буквы С. Проводники располагаются на двух активных 
слоях и имеют противоположную ориентацию (горизонтальную или вертикаль-
ную). Трассировка типа С более гибкая, чем трассировки типа L и Z, так как 
проводникам разрешается размещаться на расстоянии более 100 mil вне прямо-
угольника, вершины которого находятся в соединяемых выводах; 

Any Node (2 vias) – попытка провести проводники между любыми узлами 
цепи для обеспечения наиболее полной разводки при простановке не более двух 
ПО (на предыдущих проходах проводники разводились из условия минимизации 
их длины); 

Maze Routes – трассировка типа «лабиринт», способная найти путь для оп-
тимальной прокладки проводника, если это физически возможно. Максимальное 
число ПО в каждой цепи назначают с помощью атрибута MAXVIAS, который по 
умолчанию равен 10. Если лабиринтная трассировка заблокирует разводку ряда 
цепей, то поступают следующим образом: 1) выключают алгоритм Maze и с по-
мощью Quick Route разводят ПП; 2) разводят ряд проводников вручную с помо-
щью PCAD РСВ; 3) завершают трассировку с помощью Quick Route, включив 
алгоритм Maze; 

Any Node (maze) – попытка провести проводники между любыми узлами 
цепи с помощью алгоритма «лабиринт» (необязательно оптимальным образом); 

Route Cleanup – улучшение внешнего вида ПП (manufacturing). На этом 
проходе часть проводников разводятся заново для их спрямления, где это воз-
можно; 

Via Minimization – минимизация количества ПО. Если необходимо сохра-
нить расположение ряда предварительно размещенных ПО, следует или не ис-
пользовать данный проход, или заменить эти ПО выводами со штыревыми от-
верстиями. 

Трассировка начинается после нажатия на клавишу Start в меню Quick 
Route. При этом одновременно изменяется вид экрана, как показано на рис. 3.4.  

По команде Route>Info выводится текущая информация о результатах 
трассировки. По команде Route>Cancel трассировка прекращается. 

В рабочем окне на экране приводится изображение ПП. После прокладки 
проводника его изображение сразу же появляется на экране. Сообщение Route 
completed указывает о завершении трассировки. Одновременно выводятся дан-
ные о проценте разведенных цепей. Кроме того, в скобках приведено число раз-
веденных цепей и общее число цепей, отделенное косой чертой. 
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Рис. 3.4. Экран трассировщика Quick Route 

 
Информация о стратегии трассировки, результатах выполнения отдельных 

фаз трассировки и итоговые данные помещаются в файл протокола, имеющий 
расширение имени .LOG.  

Ограничения Quick Route:  
- разрешены только простые КП и ПО (имеют одну и ту же форму на всех 

слоях), глухие межслойные ПО не допускаются; 
- для цепей, не имеющих атрибута AUTOROUTEWIDE, допускается только 

один стиль ПО; 
- диаметр ПО не может более чем в два раза превышать текущий шаг сетки 

трассировки; 
- разрешенные размеры сетки трассировки: 12,5 mil, 16,7–16,6–16,7 mil, 

20 mil и 25 mil. Метрическая сетка не разрешается; 
- ширина проводника не может быть больше половины шага сетки; 
- для ПО нельзя создать специальную сетку; 
- выводы компонентов можно повернуть только на 90°; 
- допускается не более 4 слоев металлизации. 
Расположение объектов вне сетки трассировки. Если вывод компонента 

не совпадает с узлом выбранной сетки, то трасса проводника подводится к бли-
жайшему пути и от него будет проложен короткий сегмент до центра КП. По-
этому не совпадающие с узлами сетки выводы компонентов способствуют бло-
кированию каналов трассировки. Поэтому рекомендуется так располагать ком-
поненты, чтобы все их выводы совпадали с узлами сетки. 

Особенности трассировки компонентов с планарными выводами. Quick 
Route позволяет выбрать предпочтительную ориентацию проводников на каж-
дом слое трассировки. Для двусторонних ПП обычно выбирается горизонталь-
ная ориентация проводников на верхнем слое (Тор) и вертикальная на нижнем 
(Bottom). Однако это соглашение препятствует трассировке компонентов с пла-
нарными выводами. Например, если на верхней стороне ПП размещен планар-
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ный разъем, ориентированный параллельно нижнему краю ПП, к его средним 
выводам будет очень трудно подвести проводники. Для облегчения автоматиче-
ской разводки компонентов с планарными выводами Quick Route генерирует ря-
дом с каждым планарным выводом сквозное ПО (стрингер) и соединяет его с 
ним коротким проводником. После завершения разводки неиспользованные ПО 
автоматически удаляются. 

По умолчанию ПО имеют на внутреннем слое металлизации КП с тепловы-
ми барьерами. Если же двусторонняя ПП имеет металлизированный нижний 
слой, то на нем применяется непосредственное соединение контактных площа-
док (Direct Connect). 

Выбор сетки трассировки. В Quick Route можно выбрать одну из четырех 
сеток трассировки: регулярные сетки с шагом 25, 20, 12,5 mil и нерегулярная 
сетка 16,7-16,6–16,7 mil. Перед выбором шага сетки и ширины проводников не-
обходимо выяснить на предприятии, где будет изготавливаться ПП, принятые 
технологические нормы. 

Выполнение предварительных расчетов по выбору сетки и расположение 
компонентов абсолютно необходимо. Если разместить компоненты в сетке с ша-
гом 50 mil, то возможен выбор шага сетки трассировки 25, 16,7-16,6–16,7 или 
12,5 mil. Наименьший шаг сетки размещения, при которой возможно примене-
ние всех имеющихся в Quick Route сеток разводки, составляет 100 mil. При не-
согласованном выбор сеток размещения и разводки многие выводы компонентов 
не будут попадать в узлы сетки разводки, что не позволит достичь наиболее вы-
сокой степени разводки. 

Выбор размеров контактных площадок. Кроме выбора оптимального ша-
га сетки размещения компонентов необходимо выбрать размеры КП, чтобы 
обеспечить возможность прокладки нескольких проводников между соседними 
выводами. В табл. 3.1 приведены рекомендуемые значения максимальных раз-
меров КП и ПО для каждого шага сетки трассировки. 

Таблица 3.1 
Рекомендуемые размеры контактных площадок и ПО 

Рекомендуемый диаметр, mil
Шаг сетки, mil 

КП штыревых  
выводов ПО 

Ширина  
планарных  
выводов, mil 

25 62 40 – 
20 50 40 – 

16,7-16,6-16,7 40 40 – 
12,5 54 32 30 

 
2.5. Бессеточный трассировщик Shape-Based Router 

В программе Shape-Based Router используются принципы оптимизации 
нейронных сетей, и она в основном предназначена для трассировки многослой-
ных ПП с высокой плотностью размещения компонентов в автоматическом, ин-
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терактивном и ручном режимах; особые преимущества имеет при наличии пла-
нарных компонентов, выполненных в разных системах единиц (метрической и 
английской). 

Кроме того, эта программа основана на так называемой Shape-Based, или 
бессеточной технологии. Согласно ей все объекты ПП моделируются в виде со-
вокупности геометрических фигур (прямоугольник, круг, дуга, трасса, полигон). 
В отличие от привязанных к сеткам технологиям (Grid-Based), используемым, в 
частности, в PCAD Quick Route, при бессеточной технологии каждый объект 
моделируется не набором узлов сетки, а геометрически точно, за счет чего дос-
тигается более плотный монтаж. Характерная особенность бессеточной техноло-
гии – меньшие затраты памяти компьютера. 

Программа Shape-Based Router нацелена на решение глобальных проблем 
(100 %-ная трассировка, минимизация количества ПО и др.) и не позволяет вы-
полнить тонкую настройку стратегии трассировки (например, определенную 
цепь заключить в экран, провести дифференциальную пару проводников, про-
ложить индивидуальную цепь заданной длины и т. п.).  

Shape-Based Router обрабатывает ПП, имеющие до 30 слоев, до 4000 ком-
понентов, до 5000 выводов в одном компоненте, до 10 000 цепей и до 16 000 
электрических соединений. 

Программа Shape-Based Router может быть вызвана автономно из среды 
Windows (файл SR.EXE) или из меню Route PCAD PCB (команда Autorouters). 
В диалоговом окне вызова этой программы можно только указать имена файлов: 
исходной ПП в формате PCAD Route File (*.PRF), выходной (оттрассированной) 
ПП в формате PCAD PCB (*.pcb), протокол команд (*.LOG). По умолчанию эти 
файлы получают те же имена, что и файл исходного проекта, но в начале имени 
выходных файлов добавляется префикс R. 

В Shape-Based Router передаются из PCAD PCB значения ширины трасс, 
присвоенные цепям с помощью атрибутов Width, и тип ПО, установленный по 
умолчанию. В качестве глобального зазора Primary Clearance принимается зазор 
Line to Line, заданный для слоя Bottom (его можно в дальнейшем изменить). 
Трассы, проложенные вручную, защищаются от изменений по команде Edit>Fix. 
Экран Shape-Based Router изображен на рис. 3.5. 

Настройка стратегии трассировки. По команде Options>Auto-Router от-
крывается диалоговое окно настройки стратегии трассировки (рис. 3.6), имею-
щее 3 закладки. На закладке Routing Passes в полях Router Passes и Manufacturing 
Passes выбирается тип трассировки: 

Memory – трассировка типа «память»; 
Fan Out User SMD Pins – генерация веерообразно расположенных стринге-

ров для выводов планарных компонентов; 
Pattern – трассировка фрагментов ПП с использованием типовых образцов, 

имеющихся в программе (рекомендуется включать всегда); 
Shape Router – Push And Shove – раздвигание и отталкивание ранее проло-

женных мешающих трасс; 
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Рис. 3.5. Экран программы Shape-Based Router 

 
Shape Router – Rip Up – разрыв и повторная трассировка трасс, проложен-

ных на предыдущих проходах с нарушениями (превышение допустимых зазоров 
или пересечение на одном слое); 

Clean During Routing – уменьшение количества изгибов трасс и удаление 
лишних ПО в процессе трассировки; 

Clean After Routing – уменьшение количества изгибов трасс и удаление 
лишних ПО после трассировки; 

Evenly Space Traces – равномерное распределение трасс; 
Add Testpoints – вставка контрольных точек. 
В поле Options выбирается тип изгибов трасс Routed Corners: под углом 90 

или 45°. 
На закладке Parameters в поле Router Direction для каждого слоя ПП выби-

рают предпочтительную ориентацию трасс из следующего перечня: 
Auto – предоставление выбора программе; 
Disable – запрет для трассировки; 
Fan Out – генерация веерообразно расположенных ПО, соединенных с вы-

водами планарных компонентов короткими отрезками трасс (стрингерами); 
Plane – резервирование слоя для использования в качестве слоя металлиза-

ции; 
Vertical – вертикальная; 
Horizontal – горизонтальная; 
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а б 

 
в 

Рис. 3.6. Диалоговое окно Autorouter Setup: a – закладка Routing Passes,  
б – закладка Parameters, в – закладка Testpoints 

 
1 o'clock, 2 o'clock, 4 o'clock, 5 o'clock, 45/, 45\\ – выбор одной из ориента-

ции (разрешается для многослойных ПП); 
Any Direction – отказ от прокладки трасс определенной ориентации (разре-

шается для многослойных ПП). 
Нажатие на панель Analyze Directions выбирает предпочтительное направ-

ление трассировки слоев, имеющих признак Auto. Кроме того, назначаются сле-
дующие параметры (рис. 3.6, б): 

Units – система единиц величин, отображаемых на экране дисплея (Mils, 
Inches, Centimeters, Millimeters, Microns; на точность трассировки не влияет); 

Via Type – запрет (No Vias), разрешение (Thruhole Only) использования ПО; 
Via under SMD – запрет (No), разрешение (Yes) размещения ПО под КП 

планарных компонентов; 
Channel Size – размер канала трассировки, равный сумме ширины трассы 
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Primary Trace Width и допустимого зазора Primary Clearance. Это значение может 
быть изменено; для выполнения бессеточной трассировки назначается 1 mil и 
менее. 

Primary Pad Size – диаметр большинства КП выводов штыревых компонен-
тов. Если штыревых компонентов нет, то этот параметр равен наибольшему раз-
меру КП планарных компонентов (используется при расчете Channel Size); 

Primary Via Width – диаметр ПО, выбранного в PCAD РСВ в качестве ПО 
по умолчанию; 

Primary Trace Width – ширина большинства трасс ПП (устанавливается 
программой на основе анализа таблицы цепей меню команды Edit>Net; исполь-
зуется при расчете Channel Size и прокладке трасс, которым в PCAD РСВ не был 
назначен атрибут Width); 

Primary Clearance – минимально допустимый зазор между любыми объек-
тами, т.е. Track to Track, Track to Pad, Track to Via, Via to Pad (устанавливается в 
PCAD PCВ, но может быть изменен). 

Для облегчения доработки ПП после ее трассировки рекомендуется не из-
менять значение Channel Size, рассчитанное программой. Бессеточная трасси-
ровка (с шагом сетки 1 mil и менее) целесообразна в проектах, имеющих боль-
шое разнообразие значений ширины трасс и зазоров. При использовании значе-
ния Cannel Size, установленного программой, нет разницы между качеством се-
точной и бессеточной трассировки.  

На закладке Testpoints (рис. 3.6, в) устанавливается приоритет размещения 
контрольных точек (КТ), размещаемых на ПП, если на закладке Routing Passes 
отмечена опция Add Testspoints. 

По команде Edit>Net Attributes открывается диалоговое окно (рис. 3.7) за-
дания атрибутов всем цепям проекта: 

Display – разрешение (True) или запрет (False) отображения цепи; 
Routing Priority – приоритет трассировки (Default, 1, 2, ..., 20); 
Length Minimize (минимизация длины трассы цепи); 
Route Action (тип трассировки); 
Routing Layer (слой трассировки); 
Width – ширина трассы. По умолчанию указывается значение, равное пара-

метру Primary Trace Width; однако оно может быть изменено (выбрано из пред-
лагаемого набора или введено самостоятельно). 

Перед выполнением трассировки полезно ознакомиться со статистическими 
данными о ПП по команде Reports>Pre-Route Synopsis для внесения при необ-
ходимости коррекции в исходную ПП или стратегию трассировки. Полезная ин-
формация о плотности связей ПП может быть получена также по команде 
View>Density. 

Автотрассировка всей ПП начинается по команде Tools>Start Autorouter 
. Интерактивная трассировка выполняется по другим командам меню Tools: 

AutoRoute Connection , AutoRoute Net , AutoRoute Component , Auto-
Route Area . Ручная прокладка трассы выполняется по команде Manual Route 
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. С помощью команды Tools>Sketch Route курсором рисуется примерное 
расположение трассы выбранной цепи, которая прокладывается затем автомати-
чески. 

 

 
Рис. 3.7. Диалоговое окно Net Attributes 

 
По завершении трассировки по командам Reports>Routing Statistics,  

Reports>Reports можно просмотреть итоговые отчеты. 
Возвращение в PCAD РСВ после трассировки производится по команде 

File>Save and Return. 
 

3. Порядок выполнения работы 
1. Загрузить в PCAD Schematic схему электрических соединений, создан-

ную на лабораторной работе № 2 по индивидуальному заданию. 
2. Транслировать соединения в файл списка цепей по команде 

Utils>Generate Netlist. 
3. Загрузить программу PCAD PCB, установить требуемую конфигурацию и 

подключить библиотеки, из которых будут браться компоненты для создания 
схемы, используя команду Library>Setup... 

4. Командой Utils>Load Netlist загрузить сведения о схеме. 
5. В слое Board нарисовать контур платы согласно рассчитанным размерам. 
6. Разместить компоненты внутри контура платы. 
7. Настроить параметры программы трассировки по команде 

Route>Autorouters… согласно индивидуальному заданию (табл. 3.2). 
Таблица 3.2 

Варианты индивидуальных заданий 
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Вариант 
(Приложение) Автотрассировщик Количество  

слоев 
Класс точности ПП 
(ГОСТ 23751-86) 

1 Quick Route 2 3 

2 Shape-Based Router 4 4 

3 Quick Route 2 2 

4 Shape-Based Router 2 3 

5 Quick Route 4 4 

6 Shape-Based Router 2 3 
 
8. Провести трассировку печатных проводников платы. 
9. Получить распечатку результатов выполнения работы. 
10. Оформить отчет по лабораторной работе. 
 

4. Содержание отчета 
1. Цель работы. 
2. Результаты выполнения работы в виде таблиц текстового отчета о плате и 

оттрассированной платы печатной. 
3. Электронная версия результатов трассировки. 
4. Выводы. 
 

5. Контрольные вопросы 
1. Какие стандартные слои генерируются при работе PCAD PCB. 
2. Особенности работы с парными слоями при размещении компонентов на 

плате. 
3. Виды стеков контактных площадок и особенности их применения. 
4. Алгоритм разработки печатных плат в PCAD PCB. 
5. Виды трассировщиков печатных соединений в PCAD PCB. 
6. Какие вы знаете типы трассировки, выполняемой программой Quick 

Route? 
7. Для чего необходимо указывать технологические ограничения при про-

ектировании печатных плат? 
8. Какие особенности трассировщика Shape-Based Router вы знаете? 
9. Преимущества автоматизированного проектирования печатных плат. 
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ПРИЛОЖЕНИЕ 
 

Вариант 1 

 
 

Поз. 
обознач. 

 
Наименование 

 
Кол. 

 
Примечание

    
 Конденсаторы   
    

С1  SMD 100 пФ±5% - 50 В – Х7R 1  
С2, C3  SMD 0,47 мкФ±5% - 50 В – Х7R 2  
С4  К50-35 – 100 мкФ – 25В - ±20% 1  

С5, С6  К50-35 – 470 мкФ – 25В - ±20% 2  
    

DA1  Микросхема К174УН3 1  
    

XP1-XP3  Вилка PWC-10-2-F 3  
    
 Резисторы   
    

R1  SMD 1206 - 5.1 кОм±5% 1  
R2  SMD 1206 - 1 кОм±5% 1  
R3  SMD 1206 – 2.2 кОм±5% 1  
R4  SMD 1206 - 1 кОм±5% 1  

R5, R6  SMD 1206 - 470 Ом±5% 2  
R7  SMD 1206 - 100 Ом±5% 1  
R8  SMD 1206 - 1 кОм±5% 1  
R9  SMD 1206 - 100 Ом±5% 1  
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Вариант 2 

 
 

Поз. 
обознач. 

 
Наименование 

 
Кол. 

 
Примечание

    
 Конденсаторы   
    

С1 К50-35 – 470 мкФ – 25В - ±20% 1  
С2 SMD Х7R 0,47 мкФ±5% - 50 В  1  
С3 SMD Х7R 100 пФ±5% - 50 В 1  
С4 SMD Х7R 680 пФ±5% - 50 В 1  

C5, C6 SMD Х7R 0,47 мкФ±5% - 50 В  2  
С7 SMD Х7R 680 пФ±5% - 50 В 1  
C8 SMD Х7R 0,47 мкФ±5% - 50 В  1  

    
DA1 Микросхема К174УН7 1  

    
XP1-XP3 Вилка PWC-10-2-F 3  

    
 Резисторы   
    

R1 SMD 3214G - 47 кОм±5% 1  
R2 SMD 1210 - 1 кОм±5% 1  
R3 SMD 1210 – 2.2 кОм±5% 1  
R4 SMD 1210 – 51 кОм±5% 1  
R5 SMD 1210 - 1 МОм±5% 1  
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Вариант 3 

 
 

Поз. 
обознач. 

 
Наименование 

 
Кол. 

 
Примечание

    
 Конденсаторы   
    

С1…C3 SMD Х7R 100 пФ±5% - 50 В 3  
С4 SMD Х7R 0,47 мкФ±5% - 50 В  1  

С5, С6 SMD Х7R 51 пФ±5% - 50 В 2  
C7 SMD Х7R 51 пФ±5% - 50 В 1  

C8, С9 SMD Х7R 680 пФ±5% - 50 В 2  
С10 SMD Х7R 680 пФ±5% - 50 В 1  

    
DA1 Микросхема КR1021HA2 1  

    
 Соединители   
    

XP1 PWC-10-4-F 1  
XP2 FR-2 1  

    
 Резисторы   
    

R1, R2 SMD 3214G - 30 кОм±5% 2  
R3 SMD 1210 – 0,47 MОм±5% 1  

R4, R5 SMD 1210 – 2.2 кОм±5% 2  
R6 SMD 1210 – 51 кОм±5% 1  
R7 SMD 1210 - 100 кОм±5% 1  
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Вариант 4 

 
 

Поз. 
обознач. 

 
Наименование 

 
Кол. 

 
Примечание

    
 Конденсаторы   
    

С1 SMD Х7R 0,1 мкФ±5% - 50 В 1  
С2 SMD Х7R 0,47 мкФ±5% - 50 В 1  

С3, C4 SMD Х7R 100 пФ±5% - 50 В 2  
    
 Микросхемы   
    

DD1 К555ЛА12 1  
DD2 К555ТМ2 1  

    
XP1 Вилка FR-2 1  

    
 Резисторы   
    

R1 SMD 3214G - 68 кОм±5% 1  
R2, R3 SMD 1210 – 3 кОм±5% 2  

R4 SMD 1210 - 100 кОм±5% 1  
R5 SMD 3214G - 68 кОм±5% 1  

    
VD1…VD3 Диод SMD DO-214AC  3  

    
VT1 Транзистор КТ361Г 1  
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Вариант 5 

 
 

Поз. 
обознач. 

 
Наименование 

 
Кол. 

 
Примечание

    
 Конденсаторы   
    

С1, С2 SMD Х7R 1 нФ±5% - 50 В 2  
C3 К50-35 – 10 мкФ – 25В - ±20% 1  
С4 SMD 6032C-2,2 мкФ±10% - 16 В 1  

    
 Микросхемы   
    

DA1 TDA2003 1  
DD1 XR2206 1  

    
XP1, XP2 Вилка WF-2  2  

    
 Резисторы   
    

R1, R2 SMD 1210 – 5,1 кОм±5% 2  
R3 SMD 1210 – 1 кОм±5% 1  
R4 SMD 1210 – 200 Ом±5% 1  
R5 SMD 1210 – 30 кОм±5% 1  
R6 SMD 1210 - 100 кОм±5% 1  

R7,R8 SMD 1210 – 10 кОм±5% 2  
R9 SMD 1210 - 3 кОм±5% 1  

R10 SMD 1210 - 10 МОм±5% 1  
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Вариант 6 
 

 
 

Поз. 
обознач. 

 
Наименование 

 
Кол. 

 
Примечание

    
 Конденсаторы   
    

С1, C2 SMD Х7R 620 пФ±5% - 50 В 2  
C3 К50-35 – 1000 мкФ – 25В - ±20% 1  

    
 Микросхемы   
    

DD1 К555ЛА3 1  
DD2 К555ПЛ3 1  

    
 Соединители   
    

XP1, XP2 PWC-10-2-F 2  
XP3 WF-2  1  

    
 Резисторы   
    

R1 SMD 1210 – 100  кОм±5% 1  
R2 SMD 1210 – 51 кОм±5% 1  
R3 SMD 1210 – 6,8 кОм±5% 1  
R4 SMD 1210 - 1 MОм±5% 1  
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