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Abstrac 

A method for modeling thermal processes occurring in the construction of electronic modules based on the 

models created in CAD by Altium Designer and SolidWorks has been developed. Engineering analysis was carried 

out in the module SolidWorks Simulation. The rationale for using the finite element method as a method for solv-

ing mathematical models describing thermal processes occurring in the construction of electronic systems is pre-

sented. A step-by-step algorithm for the engineering analysis of thermal processes that can be used for any CAE 

systems based on the finite element method is considered. 

Аннотация 
Разработана методика моделирования тепловых процессов, протекающих в конструкциях электрон-

ных модулей на основе моделей, созданных в САПР Altium Designer и SolidWorks. Инженерный анализ 

проводился в модуле SolidWorks Simulation. Представлено обоснование использования метода конечных 

элементов, в качестве метода решения математических моделей, описывающих тепловые процессы, про-

текающие в конструкциях электронных систем. Рассмотрен пошаговый алгоритм проведения инженер-

ного анализа тепловых процессов, который может быть использован для любых CAE систем, основанных 

на методе конечных элементов.  
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Постановка проблемы. Одной из важнейших 

задач при создании конструкций радиоэлектрон-

ных средств (РЭС) является анализ и обеспечение 

тепловых режимов. Появление мощных систем ав-

томатизированного проектирования (САПР) позво-

ляет все шире использовать методы оценки и рас-

чета тепловых режимов на основе численного мо-

делирования. Основной задачей в этом случае 

является получение достоверной информации о по-

ведении проектируемого или реального объекта ис-

следования при воздействии на него дестабилизи-

рующих факторов. Основная роль отводится дис-

кретным моделям, ориентированным на 

использование численных методов, например, ме-

тода конечных элементов [1–16]. 

Численное (математическое) моделирование 

позволяет проводить исследование на ранних эта-

пах, когда объект проектирования представлен тех-

нической документацией [17]. В этом случае появ-

ляется возможность проведения проектных иссле-

дований без использования макетов, опытных 

образцов, и получить информацию для прогнозиро-

вания поведения объекта в процессе эксплуатации.  

В связи с постоянным повышением требова-

ний к качеству и надежности радиоэлектронных из-

делий, непрерывным увеличением степени инте-

грации, уменьшением размеров элементов, во-

просы отвода тепла, моделирования и оптимизации 

тепловых процессов при разработке этих изделий 

приобретают особую актуальность. 

В настоящее время, общая тенденция миниа-

тюризации микроэлектронных изделий решается 

не только за счет минимизации одного размера, но 
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и более полного использования объема. Здесь 

можно выделить два направления: системы на кри-

сталле и модульные конструкции (системы в кор-

пусе). 

Системы на кристалле являются предметом ис-

следований и разработок последнего десятилетия. 

Они должны решить задачу дальнейшего повыше-

ния степени интеграции не только отдельной мик-

росхемы (микропроцессор, память, преобразова-

тель и т. д.), но и функционального блока, включая, 

так называемые, блоки с интеллектуальными свой-

ствами. 

Все эти тенденции требует применения 

средств математического моделирования на всех 

этапах проектирования микроэлектронных изде-

лий. 

По мере усложнения микроэлектронных изде-

лий и появления новых изделий, вопросы отвода 

тепла, разработки математических моделей и мето-

дов расчета их тепловых режимов приобретают 

особую актуальность. В настоящее время подси-

стемы САПР микроэлектронных изделий, связан-

ные с моделированием тепловых процессов, стано-

вятся неотъемлемой часть этих САПР. 

В современных исследованиях, представлен-

ных в научно-технической литературе, большое 

внимание уделяется методу конечных элементов, 

как способу решения математических моделей теп-

ловых процессов, прорабатываются вопросы повы-

шения точности результатов и оптимизации ма-

шинного времени решения поставленных задач. В 

настоящее время существует достаточно большое 

количество работ, рассматривающих вопросы теп-

ловых режимов электронных систем, моделирова-

ние этих процессов в различных CAE (Computer-

aided engineering) системах, а также содержащих 

результаты исследований методов и средств за-

щиты электронных систем от негативных тепловых 

процессов (Алямовский A.A., Репнев Д.Н., Мельни-

ков А.А., Сулейманов С.П., Бесшейнов А.В., Басов 

К.С.). Заслуживают внимания работы Aziz A.K., 

Cook R.D. и BarthilR.L. и других зарубежных авто-

ров. 

В исследованиях, представленных в научно-

технической литературе, приведены результаты, 

подтверждающие негативное воздействие тепло-

вых процессов на изделия электроники. Однако во-

просам моделирования этих процессов не уделя-

ется должного внимания. В этой связи исследова-

ния по данной тематике, направленные на 

разработку методики моделирования тепловых 

процессов, протекающих в конструкциях электрон-

ных систем являются актуальными. 

Тенденции развития современной микро-

электроники и проблемы обеспечения тепловых 

режимов электронных систем. Основной тенден-

цией развития микроэлектроники является повы-

шение степени интеграции микросхем [18, 19]. Су-

ществует ряд конструкторско-технологических 

проблем, которые приходится решать при проекти-

ровании и производстве микроэлектронных изде-

лий. 

Одной из важнейших проблем, вызываемой 

микроминиатюризацией ИС, является проблема 

теплоотвода. Повышение степени интеграции 

обычно связано с уменьшением как размеров самих 

элементов, так и расстояний между ними, что ведет 

к увеличению удельной мощности рассеивания. 

При нормальных условиях эксплуатации допусти-

мая мощность рассеивания современных микро-

схем не превышает 0,05 Вт/мм2, что ограничивает 

плотность размещения элементов на подложке. 

Следует отметить, что тенденции развития 

микроэлектроники во многом изменили и концеп-

цию проектирования радиоэлектронных средств 

[20, 21]. Одним из факторов, повлиявших на кон-

цепцию проектирования РЭС, стало развитие при-

боров программируемой логики, яркими предста-

вителями которых являются программируемые ло-

гические интегральные схемы (ПЛИС) [22, 23], 

применяемые для построения разнообразных ин-

терфейсных узлов, устройств управления и кон-

троля и т.д. Современные образцы ПЛИС, выпол-

ненные по 0,22-микронной технологии, способны 

работать на частотах до 300 МГц и реализуют до 3 

млн. эквивалентных логических вентилей. Это поз-

волило разработчикам сконцентрировать в едином 

модуле такое количество «логики», которое раньше 

можно было разместить лишь на нескольких функ-

циональных ячейках, заполненных интегральными 

схемами. Таким образом, радиоэлектронные си-

стемы с регулярной структурой и небольшими рас-

сеиваемыми мощностями на элементах были вы-

теснены более компактными и быстродействую-

щими системами с локализованными источниками 

тепла. 

Этот переход заставил инженеров пересмот-

реть методы построения тепловых моделей РЭС и 

расчета показателей теплового режима.  

Рассмотрим три наиболее широко применяе-

мых ранее метода теплового моделирования РЭС. 

Метод однородного анизотропного тела [24, 

25] состоит в представлении реальной конструкции 

или её части однородным анизотропным телом в 

виде прямоугольного параллелепипеда или иной 

простой геометрической фигуры, для которого 

находят эквивалентные коэффициенты теплопро-

водности по направлениям осей координат 

𝜆𝑥 , 𝜆𝑦 , 𝜆𝑧. При известных коэффициентах теплопро-

водности и геометрических размерах тела 𝑙𝑥 , 𝑙𝑦 , 𝑙𝑧 

можно определить тепловое сопротивление между 

центром тела и его поверхностью. 

Метод изотермических поверхностей [23, 24] 

предполагает выделение в конструкции поверхно-

стей с одинаковыми или условно одинаковыми тем-

пературами в каждой точке поверхности. Счита-

ется, что теплообмен осуществляется между этими 

поверхностями. В зависимости от конкретной за-

дачи исследования к изотермическим поверхно-

стям конструкций относят поверхность корпуса со 

среднеповерхностной температурой 𝑡к поверхность 

нагретой зоны с температурой 𝑡з , поверхность от-

дельной функциональной ячейки с температурой 

𝑡з𝑖, поверхность отдельного элемента с температу-

рой 𝑡э𝑖 и т.д. 
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Анализируя особенности методов можно 

прийти к выводу, что они актуальны лишь для тех 

конструкций, которые или их части можно предста-

вить однородным анизотропным телом, либо изо-

термической поверхности, иными словами при-

годны для анализа теплового режима конструкций 

с регулярной структурой. Применение этих мето-

дов для анализа теплового режима конструкций с 

нерегулярной структурой делает их чрезвычайно 

трудоемкими и повышает погрешность получае-

мых результатов. 

По этой причине, развитие элементной базы 

заставило искать новые методы, пригодные для 

анализа теплового режима конструкций с локализо-

ванными источниками тепла. Пригодными для этих 

целей оказались методы, основанные на решениях 

системы дифференциальных уравнений. 

Метод конечных разностей [25, 26] предпола-

гает дискретизацию независимой переменной х, т.е. 

строится множество или сетка 1 + 1 дискретных 

равноотстоящих точек 𝑥𝑖(𝑙 = 0, 1, 2, … , 𝐿)на от-

резке 0 ≤ 𝑥 ≤ 𝐿𝑥 с 𝑥0 = 0,  𝑥1 = 𝐿𝑥,  𝑥𝑖+1 − 𝑥1 =
∆𝑥. 

Следующий шаг состоит в замене в дифферен-

циальном уравнении членов, содержащих диффе-

ренцирование, членами, в которых используются 

только алгебраические операции. Этот процесс 

включает в себя аппроксимацию и выполняется пу-

тем использования конечно-разностных аппрокси-

маций для производных функции. Метод конечных 

разностей с одинаковым успехом может быть при-

менен для решения линейных и нелинейных крае-

вых задач и для решения задач теплопроводности. 

Однако, продемонстрированные методом возмож-

ности дискретизации, для решения обыкновенных 

дифференциальных уравнений и уравнений с част-

ными производными, при увеличении размерности 

задачи становятся крайне затруднительными. 

Оптимизация алгоритмов аппроксимации и 

нахождения численного решения привела к альтер-

нативному подходу в разбиении области (модели) 

на ряд неперекрывающихся областей или элемен-

тов с последующим построением аппроксимации 

кусочным образом. Используемые в процессе ап-

проксимации базисные функции также определя-

ются кусочным образом с применением различных 

уравнений для различных подобластей. Данный ме-

тод получил название метода конечных элементов 

(МКЭ). 

Построение тепловых моделей методом ко-

нечных элементов. В настоящее время область 

применения метода конечных элементов очень об-

ширна и охватывает все физические задачи, кото-

рые могут быть описаны дифференциальными 

уравнениями. Наиболее важными преимуществами 

метода конечных элементов, благодаря которым он 

широко используется, являются следующие: 

– свойства материалов смежных элементов не 

должны быть обязательно одинаковыми (это позво-

ляет применять метод к телам, составленным из 

разных материалов); 

– криволинейная область может быть аппрок-

симирована с помощью прямолинейных элементов 

или описана точно с помощью криволинейных эле-

ментов (таким образом, метод может быть исполь-

зован для областей с различными геометрическими 

формами границ); 

– размеры элементов могут быть переменными 

(это позволяет укрупнить или измельчить сеть раз-

биения области на элементы, если в этом есть необ-

ходимость); 

– с помощью метода конечных элементов не 

представляет труда рассмотрение граничных усло-

вий с разрывной поверхностной нагрузкой, а также 

смешанных граничных условий. 

Указанные выше преимущества метода конеч-

ных элементов могут быть использованы при со-

ставлении достаточно общей программы для реше-

ния частных задач определенного класса. Напри-

мер, с помощью программы для 

осесимметрической задачи о распространении 

тепла можно решать любую частную задачу этого 

типа. 

Анализируя вышеперечисленные свойства ме-

тода конечных элементов можно сделать вывод, 

что он имеет более широкий круг решаемых задач, 

более высокую точность и универсальность по 

сравнению с рассмотренными выше методами од-

нородного анизотропного тела и метода изотерми-

ческих поверхностей. Несмотря на это, присут-

ствует ряд факторов, сужающих круг задач, решае-

мых при помощи МКЭ. 

Главный недостаток метода конечных элемен-

тов заключается в необходимости составления вы-

числительных сложных программ и применения 

вычислительной техники. Вычисления, которые 

требуется проводить при использовании метода ко-

нечных элементов, слишком громоздки для руч-

ного счета даже в случае решения очень простых 

задач. Для решения сложных задач необходимо ис-

пользовать быстродействующую электронно-вы-

числительную машину (ЭВМ), обладающую не 

только большим объемом оперативной памяти, но 

также и ядром процессора, предназначенным для 

решения задач с потоковым типом данных. В слу-

чае отсутствия подобной ЭВМ, решение сложных 

инженерных задач при помощи САПР, использую-

щей метод конечных элементов, становится трудо-

емким процессом. 

Нельзя сказать, что вышеперечисленные недо-

статки являются в основной части недостатками 

непосредственно МКЭ, напротив, сам метод потен-

циально пригоден для решения обширного круга 

задач разных направлений. Ограничивают круг за-

дач, решаемых МКЭ, обобщенные алгоритмы рас-

чётных модулей САПР, предназначенные для ре-

шения универсальных задач и не имеющие оптими-

зации для решения задач определённого типа, чем 

весьма затрудняют получение точных результатов 

в течение небольшого количества времени. Иными 

словами, временные затраты при решении задач 

теплового режима при помощи САПР весьма суще-

ственны, что, порой, затрудняет отработку того или 

иного варианта конструкции на ранних стадиях 

проектирования устройства. 
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Поскольку целью исследований является раз-

работка методики моделирования тепловых про-

цессов, протекающих в конструкциях ЭС с приме-

нением САПР, использующих в расчетах тепловых 

режимов алгоритмы, основанные на применении 

метода конечных элементов, при сохранении задан-

ной точности решения, следует более подробно 

остановиться на тех свойствах метода конечных 

элементов, которые окажутся полезными в дости-

жении поставленной цели: 

– повышение точности расчета с увеличением 

числа конечных элементов. Данное свойство тесно 

перекликается с вопросами сходимости метода 

МКЭ и точностью аппроксимации имеющейся мо-

дели сеткой конечных элементов; 

– возможность регулирования сетки конечных 

элементов по различным параметрам. К таким па-

раметрам можно отнести размеры конечного эле-

мента, его геометрическую форму, вид аппрокси-

мации внутри конечного элемента, шаг дискретиза-

ции сетки. 

Указанные выше свойства предоставляют воз-

можность управлять точностью метода на различ-

ных участках модели, с целью снижения общего ко-

личества конечных элементов модели, а значит и 

снижению затрат машинного времени посредством 

повышения точности расчета в наиболее интересу-

ющих участках модели. Под моделью следует по-

нимать геометрическую трехмерную имитацию 

объекта, созданную при помощи САПР. Для оценки 

временных затрат при расчете тепловых режимов 

ЭС в САПР, рассмотрим основные факторы, опре-

деляющие размерность задачи расчета тепловых 

режимов ЭС в САПР. 

Создание трехмерной модели исследуемой 

электронной системы. Рассмотрим методику со-

здания трехмерной модели печатной платы на про-

стейшем примере – автомобильном усилителе мощ-

ности звуковой частоты (УМЗЧ). Принципиальная 

схема УМЗЧ представлена на рис. 1. 

 Рис. 1. Принципиальная схема автомобильного УМЗЧ 

 

Проектирование печатной платы (ПП) буду 

осуществлять с помощью Altium Designer. Плату 

для анализа затем можно конвертировать в 

SolidWorks.  

Создание печатной платы в Altium Designer 

можно разбить на несколько этапов. Сначала созда-

ется библиотека электрорадиоэлементов, которая 

содержит условно-графическое обозначение 

(УГО). Следующим этапом идет создание библио-

теки посадочных мест, к которым подключаются 

заранее созданные трехмерные модели ЭРЭ. Эти 

библиотеки объединяют в общую интегрирован-

ную библиотеку. На основе библиотеки УГО эле-

ментов создается схема электрическая принципи-

альная, на основе которой получаем модель платы. 

Рассмотрим методику создания модели печат-

ной платы в Altium Designer. Компоненты являются 

основными блоками электронных изделий. При 

разработке проекта каждый компонент нуждается в 

различных представлениях: условное графическое 

обозначение на схеме, посадочное место на плате 

(Footprint), описание в формате Space для модели-

рования, описание IBIS-модели для анализа целост-

ности сигналов и трёхмерное описание для объём-

ного представления готовой платы. Наличие пол-

ной совокупности этих представлений для каждого 

компонента не обязательно: достаточно предста-

вить компонент своим логическим символом. 

Для создания проекта печатной платы доста-

точно иметь УГО и посадочное место на плате. Для 

объемной визуализации необходимо иметь 3D мо-

дель элементов. 

Создание УГО компонентов. Чтобы создать 

УГО компонента на панели управления выбираем 
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File > New > Library > Schematic Library. После со-

здания файла настроим рабочее пространство на 

вкладке Library Editor Workspace (рис. 2), выбрав 

Tools > Document Options. 

 

 
Рис. 2. Графическое поле УГО 

 

Устанавливаем метрическую систему с основ-

ными единицами длины – миллиметр. 

После того, как настроили рабочее простран-

ство с помощью инструментов (меню Place) рисо-

вания создадим условный графический символ эле-

мента в соответствии с ГОСТ. 

Для создания электрического вывода в УГО 

используем команду Place > Pin, после запуска ко-

манды, устанавливаем его свойства, нажав Tab. В 

свойствах следует указать название и позиционное 

обозначение вывода. Рекомендуется указать длину 

вывода, электрический тип вывода и специальные 

символы (атрибуты), однако все параметры можно 

установить после его размещения (рис. 3). 

 
Рис. 3. Настройки вывода УГО 

 

Определим свойства компонента в окне 

Library Component Properties, при помощи команды 

Tools > Component Properties (рис. 4). 
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Рис. 4. Окно свойств компонента 

 

Контуры элемента рисуются функцией 

Place>Line. 

По выше изложенному принципу создали 

УГО, пример созданного условно-графического 

обозначения транзистора представлен на рис. 5. 

 
Рис. 5. УГО транзистора 

 

Создание посадочных мест компонентов. По-

садочное место является обязательным только при 

проектировании топологии печатной платы и не иг-

рает роли при проектировании электрической 

принципиальной схемы. Для хранения информации 

о посадочных местах компонентов используется 

файл с расширением *.pcblib, который создается 

командой File > New > Library >PCB Library или 

альтернативной командой Project > Add New to Pro-

ject > PCB Library. После создания файла необхо-

димо настроить рабочее пространство с помощью 

команды Tools > Library Options. 

Для установки контактных площадок выпол-

ним команду Plase/Pad и нажмём клавишу TAB для 

изменения параметров контактной площадки (рис. 

6). 
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Рис. 6. Параметры контактной площадки 

 

Далее требуется нарисовать изображение кор-

пуса компонента. Для создания очертания компо-

нента перейдём на слой Top Overlay (для выбора 

слоя требуется нажать кнопку с названием слоя 

внизу экрана). Далее с помощью команды Place > 

Line нарисуем контур. Пример посадочного места 

транзистора с контуром корпуса представлена на 

рис. 7. 

 
Рис. 7. Посадочное место корпуса транзистора ТО-92 

 

Для создания 3D модели платы, необходимо к 

полученным посадочным местам присоединить 3D-

модели. Все модели создаются в среде создания 

трёхмерных моделей SolidWorks. Для того чтобы 

привязать созданную к компоненту 3D модель в Al-

tium Designer, следует поступить следующим обра-

зом: 

– выбрать библиотеку посадочных мест; 

– выбрать один из элементов; 

– нажать Place – 3D Body, появится диалоговое 

окно, в котором ставим галочку, как показано на 

рис. 8 
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Рис. 8. Диалоговое окно присвоения корпусу 3D модели 

 

– выбираем Embed STEP Model, появляется об-

зор; 

– выбираем уже созданную модель в виде фор-

мата STEP. 

Следуя такой последовательности, получаем 

3D модели для созданных посадочных мест. При-

мер 3D-модель транзистора представлена на рис. 9. 

 
Рис. 9. 3D модель транзистора  

 

Также создавать 3D компоненты можно непо-

средственно в самом Altium Designer. Для этого 

нужно воспользоваться командой Размещение > 

Корпус компонента. В появившемся окне необхо-

димо выбрать тип 3D модели (вытянутый контур, 

цилиндр или сфера), указать геометрические пара-

метры компонента, его цвет, точки привязки, за-

зоры между компонентом и контактной площад-

кой.  

Чтобы завершить создание библиотеки необ-

ходимо соединить УГО компонентов и соответ-

ствующие посадочные места. Для этого необхо-

димо перейти в библиотеку УГО, выбрать изобра-

жение компонента, которому ходим добавить 
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посадочное место, и нажать кнопку Add Footprint. 

В появившемся окне выбираем библиотеку, в кото-

рой находятся созданные посадочные места, среди 

которых выбираем необходимый компонент. Ана-

логичные действия производим для всех остальных 

компонентов. На этом создание библиотечных ком-

понентов завершено. 

Проектирование электрической схемы. На ос-

нове созданной библиотеки необходимо спроекти-

ровать схему электрическую принципиальную (см. 

рис. 1). 

Принципиальную электрическую схему вы-

полняют по ГОСТ 2.701 и ГОСТ 2.702. Условные 

графические изображения элементов в электриче-

ских схемах должны соответствовать ГОСТ 2.721 – 

2.742, размеры условных обозначений – ГОСТ 

ЕСКД 2.747, 2.730 и буквенные обозначения – 

ГОСТ 2.710.  

Для формирования электрической схемы вы-

берем File > New > Schematic. Далее производим 

глобальные настройки Schematic. Для этого выбе-

рем в меню DXP > Preferences > Schematic. 

После завершения настроек подключим со-

зданные ранее библиотеки. Затем располагаем УГО 

компонентов на листе в соответствии с рис. 1. С по-

мощью команды Place > Wire соединяем элементы 

проводниками.  

Размещаем на схеме компоненты земли и пи-

тания, после того как все компоненты соединены. В 

результате получаем схему электрическую принци-

пиальную, представленную на рис. 10. 

Рис. 10. Схема электрическая принципиальная в Altium Designer 

 

После того как схема готова, производим ком-

пиляцию. В результате компиляции ошибок не об-

наружено, значит схема сделана правильно. 

Размещение компонентов на печатной плате. 

Для того чтобы приступить к размещению компо-

нентов, необходимо создать файл платы. Командой 

Project > Add New to Project > PCB добавляем файл 

платы в существующий проект. С помощью ко-

манды Design > Board Option вызываем окно пара-

метров PCB проекта и устанавливаем метрическую 

систему. Теперь необходимо упаковать соединения 

на печатную плату и разместить компоненты. По-

сле установки параметров платы импортируем ком-

поненты из принципиальной схемы с готовыми 

электрическими связями. Для этого воспользуемся 

командой Project > Import Changes from Source Doc-

uments (рис. 11). 

 
Рис. 11. Импортируемые компоненты платы 

После того как элементы импортированы, производим их размещение на плате в соответствии с прин-

ципиальной схемой. 

Необходимо создать контур платы. Для этого командой Размещение > Линия рисуем контур платы, 

после чего при помощи команды Проект > Форма платы > Задать по выделенным объектам, создаем 

плату необходимого размера. После того как плата готова, необходимо разместить крепежные отвер-

стия. Для этого воспользуемся командой Place > Pad. Размеры крепежных отверстий устанавливаем 

равными 3,2 мм (рис. 12).  
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Рис. 12. Плата с крепежными отверстиями 

 

Теперь плата полностью готова и можно полу-

чить ее 3D модель. Для этого нужно перейти в ре-

жим 3D Altium Designer командой Вид > Включить 

3D. 

В результате получили 3D модель печатной 

платы УМЗЧ в двух вариантах компоновки ЭРЭ, 

которые представлены соответственно на рис. 13, 

14. 

 
Рис. 13. Модель ПП УМЗЧ (1-й вариант компоновки)  
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Рис. 14. Модель ПП УМЗЧ (2-й вариант компоновки) 

 

Экспортирование модели печатной платы в 

SolidWorks. Для того чтобы можно было провести 

термический анализ печатной платы в SolidWorks 

Simulation, необходимо файл ПП сохранить в под-

держиваемом формате. Для этого выполняем по-

следовательность команд: File/Save Copy As, затем 

выбираем тип файла «Export IDF Board Files 

(*.brd)». Появляется окно, представленной на рис. 

15. 

 
Рис. 15. Диалоговое окно экспорта в Altium Designer 

 

В этом окне выставляем следующие опции: 

версия 3.0; метрическая система; экспорт контура 

платы (Board Outline); положение компонентов 

(Placement)  

После экспорта получаем 2 файла: .brd файл с 

контуром печатной платы и расположением компо-

нентов и .pro файл с описанием компонентов. Каж-

дое посадочное место описано координатами кон-

тура компонента и высотой. 

В платформе SolidWorks с файлами, экспорти-

рованными из различных программ ECAD, рабо-

тает приложение CircuitWorks. Перед началом им-
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порта модели проводим настройку основных пара-

метров CircuitWorks, таких как: ориентация модели 

в оси XZ, метрическая система измерений. Запус-

каем .brd файл и получаем плоскую модель платы с 

прорисованными компонентами и отверстиями 

(рис. 16). 

 
Рис. 16. Модель платы в CircuitWorks 

 

Для упрощения модели печатной платы, необ-

ходимо погасить все отверстия, кроме крепежных и 

отредактировать толщину подложки. CircuitsWorks 

автоматически создаст упрощенные модели компо-

нентов в виде параллелепипедов по габаритным 

размерам на основе моделей, импортированных из 

Altium Designer. 

После задания всех необходимых параметров, 

CircuitsWorks генерирует твердотельную 3D мо-

дель печатной платы в SolidWorks. В результате по-

лучаем модель, представленную на рис. 17. 

 
Рис. 17. 3D модель платы в SolidWorks 

 

Термический анализ печатной платы. Тер-

мический анализ ПП осуществляется с помощью 

программного пакета SolidWorks Simulation. Для 

этого в Property Manager выбираем тип исследова-

ния: термический. Для того, чтобы приступить к 

анализу, необходимо определить материал компо-

нентов на плате. Для упрощения расчетов, выби-

раем в библиотеке материалов для самой платы – 

гетинакс, для ЭРЭ – ABS-пластик. Параметры вы-

бранных материалов представлены в табл. 1. 

Таблица 1 

Свойства материалов модели 

Параметры Гетинакс ABS-пластик 

Модуль упругости Н/м2 1,5·109 2·109 

Коэффициент Пуассона 0,3 0,394 

Плотность кг/м3 1350 1020 

Предел прочности (рассяжение) 16·107 3·107 

Теплопроводность Вт/(м·К) 0,3 0,2256 

Удельная теплоемкость Дж/(кг·К) 1470 1386 

 

Следующим этапом является задание гранич-

ных условий для нашей модели. Программа позво-

ляет реализовать следующие виды тепловых воз-

действий: конвекция, температура, тепловая мощ-

ность, тепловой поток, излучение.  

Условия испытаний: воздействие 3 температур 

окружающей среды (273 К, 300 К, 323 К). 

Нас интересует стационарный тепловой про-

цесс, а именно: получить тепловую карту, которую 

в дальнейшем можно будет проанализировать. 
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Чтобы реализовать данные условия испыта-

ний, нам достаточно будет использовать 2 вида тер-

мических нагрузок: конвекция и тепловая мощ-

ность. 

Параметры конвекции: указываем грани с кон-

вективным теплообменом с окружающей средой, 

коэффициент конвективной теплоотдачи (25 

Вт/(м2∙К)), температура окружающей среды. Пара-

метры тепловой мощности: объект рассеивания, 

рассеиваемая мощность. 

После задания термических нагрузок, необхо-

димо построить сетку. Результаты создания сетки 

представлены на рис. 18. 

 
Рис. 18. Построение сетки КЭ 

 

Если при построении сетки возникли ошибки 

– устраняем, если нет – запускаем решение, которое 

будет выполняться решающей программой 

FFEPlus. 

В результате моделирования, для указанных 

температур получаем следующие тепловые карты: 

– 273 К (рис. 19);  

– 300 К (рис. 20); 

– 323 К (рис. 21);  

 

 
Рис. 19. Тепловая карта (273 К) 
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Рис. 20 – Тепловая карта (300 К) 

 
Рис. 21 – Тепловая карта (323 К) 

 

Заключение. В результате исследований были 

получены трехмерные модели печатной платы в 

разных вариантах компоновки радиоэлектронных 

элементов и проведено численное моделирование 

тепловых процессов при различных условиях окру-

жающей среды. Создание трехмерной модели и сам 

процесс моделирования тепловых процессов произ-

водились при помощи САПР Altium Designer и 

SolidWorks Simulation. 
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